aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2015-03-07 20:26:10 +0000
committerIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2015-03-07 20:26:10 +0000
commit830bfe47d5b083ddb468df8270f5e28e3a66b774 (patch)
tree33e9a5160f2fc75bf65ee9a95f22f58fc6a2a30c /Makefile.am
parent3620a1ce26b6a139e3bc6b0f13f6fe9e85ff7c4a (diff)
fixed distcheck target
note: this modifies the Makefile.am in the 'GENERATED CODE' section. so the Makefile.am generator will overwrite these fixes... (luckily we haven't published it yet) svn path=/trunk/externals/iem/iemmatrix/; revision=17438
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d6d2548..329f297 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,9 +27,20 @@ AM_LDFLAGS+=
noinst_LTLIBRARIES = libiemmatrixCore.la
libiemmatrixCore_la_SOURCES=\
+ src/iemmatrix.h \
+ src/iemmatrix_sources.h src/mtx_binop_generic.h \
src/iemmatrix_binops.c \
- src/iemmatrix_utility.c \
- src/mtx_qhull/list.c src/mtx_qhull/vectors.c src/mtx_qhull/zhull.c
+ src/iemmatrix_utility.c
+
+## qhull-stuff
+libiemmatrixCore_la_SOURCES+=\
+ src/mtx_qhull/entry.h \
+ src/mtx_qhull/list.h \
+ src/mtx_qhull/list.c \
+ src/mtx_qhull/vectors.h \
+ src/mtx_qhull/vectors.c \
+ src/mtx_qhull/zhull.h \
+ src/mtx_qhull/zhull.c
iemmatrix_la_CPPFLAGS=-DIEMMATRIX_LIBRARY $(AM_CPPFLAGS)
@@ -293,6 +304,12 @@ mtx_sndfileread_la_LIBADD =libiemmatrixCore.la
mtx_sort_la_SOURCES=src/mtx_sort.c
mtx_sort_la_LIBADD =libiemmatrixCore.la
mtx_spherical_harmonics_la_SOURCES=src/mtx_spherical_harmonics.c
+mtx_spherical_harmonics_la_SOURCES+= \
+ src/mtx_spherical_harmonics/chebyshev12.c src/mtx_spherical_harmonics/chebyshev12.h \
+ src/mtx_spherical_harmonics/legendre_a.c src/mtx_spherical_harmonics/legendre_a.h \
+ src/mtx_spherical_harmonics/sharmonics.c src/mtx_spherical_harmonics/sharmonics.h \
+ src/mtx_spherical_harmonics/sharmonics_normalization.c src/mtx_spherical_harmonics/sharmonics_normalization.h \
+ src/mtx_spherical_harmonics/sph_radial.c src/mtx_spherical_harmonics/sph_radial.h
mtx_spherical_harmonics_la_LIBADD =libiemmatrixCore.la
mtx_spherical_radial_la_SOURCES=src/mtx_spherical_radial.c
mtx_spherical_radial_la_LIBADD =libiemmatrixCore.la