aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2014-09-08 10:05:19 +0000
committerIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2014-09-08 10:05:19 +0000
commit3e8c6a5be1fec8b648ae4caea1dfb2ceb16a90a9 (patch)
treec09a44b11178f4a70e636bc998f4674151ae41f5 /src/configure.ac
parente83786985c3cf004f41a54724ce335312913ba73 (diff)
run OSX linker tests before generic unix ones
clang accepts '-shared' but does not allow '-bundle ...' on top of that which is required to actually produce externals. LATER: should we switch to autotools? svn path=/trunk/externals/iem/iemmatrix/; revision=17347
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 5830de2..1ae1e58 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -173,6 +173,11 @@ dnl
dnl OK, checks which machines are here now
dnl this needs some rethinking when cross-compiling (?)
dnl
+
+# OSX
+AC_CHECK_LDFLAGS([-bundle -undefined suppress -flat_namespace])
+
+# un*x
AC_CHECK_LDFLAGS([-shared])
if test `uname -s` = Linux;
@@ -199,11 +204,6 @@ then
fi
fi
-#AC_CHECK_LDFLAGS([-dynamiclib -mmacosx-version-min=10.3 -undefined dynamic_lookup],
-# ,
- AC_CHECK_LDFLAGS([-bundle -undefined suppress -flat_namespace])
-# )
-
if test `uname | sed -e 's/^MINGW.*/NT/'` = NT ;
then
LD=${CC}