aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2008-11-03 10:20:51 +0000
committerIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2008-11-03 10:20:51 +0000
commitba49f3d781ddda444783b1c99ca65f2148e70a33 (patch)
treee7914bb93cf98072c9dfda7fa65f7e9a43db843c /src/configure.ac
parentf19687f2bd42e6a147f813407db44c145e7bf7b5 (diff)
added checks for sndfile to configure; properly use this in mtx_sndfileread
svn path=/trunk/externals/iem/iemmatrix/; revision=10356
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index c36746e..ca98ab4 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -66,9 +66,12 @@ dnl Replace `main' with a function in -lm:
AC_CHECK_LIB(m, main)
dnl Replace `main' with a function in -lpthread:
dnl AC_CHECK_LIB(pthread, main)
-dnl Replace `main' with a function in -lstk:
+dnl Replace `main' with a function in -lfftw3:
AC_CHECK_LIB(fftw3, fftw_destroy_plan)
+dnl for soundfile reading (and writing, if we do that...)
+AC_CHECK_LIB(sndfile, sf_close)
+
if test "x$with_pd" != "x"; then
if test -d "${with_pd}/src"; then
@@ -96,7 +99,7 @@ AC_CHECK_LIB(pd, nullfn)
dnl Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(stdlib.h stdio.h string.h math.h time.h sys/time.h fftw3.h)
+AC_CHECK_HEADERS(stdlib.h stdio.h string.h math.h time.h sys/time.h fftw3.h sndfile.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_TIME