aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 5830de2..1ae1e58 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -173,6 +173,11 @@ dnl
dnl OK, checks which machines are here now
dnl this needs some rethinking when cross-compiling (?)
dnl
+
+# OSX
+AC_CHECK_LDFLAGS([-bundle -undefined suppress -flat_namespace])
+
+# un*x
AC_CHECK_LDFLAGS([-shared])
if test `uname -s` = Linux;
@@ -199,11 +204,6 @@ then
fi
fi
-#AC_CHECK_LDFLAGS([-dynamiclib -mmacosx-version-min=10.3 -undefined dynamic_lookup],
-# ,
- AC_CHECK_LDFLAGS([-bundle -undefined suppress -flat_namespace])
-# )
-
if test `uname | sed -e 's/^MINGW.*/NT/'` = NT ;
then
LD=${CC}