aboutsummaryrefslogtreecommitdiff
path: root/build/autotests/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'build/autotests/tests/Makefile.am')
-rw-r--r--build/autotests/tests/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/build/autotests/tests/Makefile.am b/build/autotests/tests/Makefile.am
new file mode 100644
index 0000000..1a5f7f7
--- /dev/null
+++ b/build/autotests/tests/Makefile.am
@@ -0,0 +1,30 @@
+AUTOMAKE_OPTIONS = foreign
+AM_LDFLAGS= -module -avoid-version -shared -shrext .pd_linux
+
+TEST_EXTENSIONS = .la
+LA_LOG_COMPILER = $(srcdir)/runtest.sh
+
+AM_CPPFLAGS=-I$(top_srcdir)/../..
+AM_LDFLAGS+=$(top_builddir)/libiemnet.la -rpath /tmp
+
+SOURCES=common.h
+noinst_HEADERS=common.h
+EXTRA_DIST=runtest.sh
+
+TESTS = \
+ pass.la skip.la fail.la \
+ serialqueue.la threadedqueue.la
+
+XFAIL_TESTS = fail.la
+
+check_LTLIBRARIES= \
+ pass.la skip.la fail.la \
+ serialqueue.la threadedqueue.la
+
+pass_la_SOURCES=pass.c
+skip_la_SOURCES=skip.c
+fail_la_SOURCES=fail.c
+
+threadedqueue_la_SOURCES=threadedqueue.c
+serialqueue_la_SOURCES=serialqueue.c
+