aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control14
-rw-r--r--debian/copyright14
-rwxr-xr-xdebian/rules15
5 files changed, 49 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..11638ad
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-bassemu (0.3-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..efc507c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: pd-bassemu
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), puredata
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-bassemu
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description: an object for transistor bass emulation
+ bassemu~ is an object that simulates a transistor-based electronic
+ synthesizer.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..6868864
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,14 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Sat, 3 Apr 2010 17:14:25 -0400
+Files: *
+Copyright: 2006, Christian Klippel
+
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 2 can be found in file "/usr/share/common-licenses/GPL-2".
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..32d99e9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+PACKAGE = pd-bassemu
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/bassemu~/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+