aboutsummaryrefslogtreecommitdiff
path: root/comport/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'comport/debian/rules')
-rwxr-xr-xcomport/debian/rules21
1 files changed, 0 insertions, 21 deletions
diff --git a/comport/debian/rules b/comport/debian/rules
deleted file mode 100755
index 935a3af..0000000
--- a/comport/debian/rules
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/usr/bin/make -f
-
-LIBRARY_NAME = comport
-PACKAGE = pd-$(LIBRARY_NAME)
-pkglibdir = /usr/lib/pd/extra
-
-%:
- dh --with quilt $@
-
-override_dh_auto_install:
- make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
-# replace license file with link to the Debian license file
- rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
-
-override_dh_shlibdeps:
- dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
- -T$(CURDIR)/debian/$(PACKAGE).substvars
-
-override_dh_strip:
- strip --remove-section=.comment --remove-section=.note --strip-unneeded \
- $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux