aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 50 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..578cf75
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,50 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT
+GEM2PDP_VERSION=0.4
+PD_DIR=/usr/local/pd
+PDP_DIR=/usr/local/pd/pdp
+GEM_DIR=/usr/local/pd/gem
+
+AC_ISC_POSIX
+AC_PROG_CC
+AM_PROG_CC_STDC
+AC_HEADER_STDC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AM_SANITY_CHECK
+
+AM_MAINTAINER_MODE
+AM_WITH_DMALLOC
+
+AC_SUBST(GEM2PDP_VERSION)
+
+echo -n "looking for gem sources (required) ... "
+if test -f $GEM_DIR/src/Base/GemMan.h
+then
+ AC_SUBST(GEM_DIR)
+ echo "ok."
+else
+ echo "gem source tree not found... install it, fix the path in configure.ac and run autoconf"
+ exit -1
+fi
+
+AC_SUBST(PD_DIR)
+
+echo -n "looking for pdp sources (required) ... "
+if test -f $PDP_DIR/include/pdp.h
+then
+ AC_SUBST(PDP_DIR)
+ echo "ok."
+else
+ echo "pdp source tree not found... install it, fix the path in configure.ac and run autoconf"
+ exit -1
+fi
+
+LIBS="$LIBS -lm"
+CFLAGS="$CFLAGS -Wall"
+
+AC_CONFIG_FILES([
+Makefile
+])
+AC_OUTPUT