aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/install_examples_into_docdir
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/install_examples_into_docdir')
-rw-r--r--debian/patches/install_examples_into_docdir22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/install_examples_into_docdir b/debian/patches/install_examples_into_docdir
new file mode 100644
index 0000000..dd3141a
--- /dev/null
+++ b/debian/patches/install_examples_into_docdir
@@ -0,0 +1,22 @@
+Description: put the 'examples' folder into /usr/share/doc/pd-* so that
+ lintian does not complain about images being in lib directory, then link to
+ it in the library so that the Pd Help Browser can find it.
+Author: Hans-Christoph Steiner <hans@eds.org>
+Forwarded: not-needed
+Reviewed-By: Hans-Christoph Steiner <hans@eds.org>
+Last-Update: <2010-11-05>
+
+--- pd-hcs-0.1.orig/Makefile
++++ pd-hcs-0.1/Makefile
+@@ -206,9 +206,9 @@
+
+ install-examples:
+ test -z "$(strip $(EXAMPLES))" || \
+- $(INSTALL_DIR) $(DESTDIR)$(objectsdir)/$(LIBRARY_NAME)/examples && \
++ $(INSTALL_DIR) $(DESTDIR)$(prefix)/share/pd-$(LIBRARY_NAME)/examples && \
+ for file in $(EXAMPLES); do \
+- $(INSTALL_DATA) examples/$$file $(DESTDIR)$(objectsdir)/$(LIBRARY_NAME)/examples; \
++ $(INSTALL_DATA) examples/$$file $(DESTDIR)$(prefix)/share/pd-$(LIBRARY_NAME)/examples; \
+ done
+
+ install-manual: