aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-01-28 00:37:54 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-01-28 00:37:54 +0000
commit6b2aa4a4a7816d604ee63c974131c03fed9a4b7c (patch)
treef2e8041327aba32123e3c45acf746a523943d188 /Makefile.am
parentd97ac3564e559040da3b87635352da0cea75ab5e (diff)
first working version of hidio+HIDUtilities build on Mac OS X using autotools, still needs work
svn path=/trunk/externals/io/hidio/; revision=13107
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ca00a6f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,39 @@
+AUTOMAKE_OPTIONS = foreign
+
+noinst_PROGRAMS = hidio
+hidio_SOURCES = hidio.c hidio_types.c
+hidio_CFLAGS = $(CFLAGS)
+hidio_LDADD =
+hidio_LDFLAGS = $(LDFLAGS)
+noinst_HEADERS = hidio.h input_arrays.h
+
+EXTRA_SUBDIRS =
+
+if MACOSX
+hidio_SOURCES += hidio_darwin.c
+EXTRA_SUBDIRS += HID_Utilities_Source
+hidio_CFLAGS += -IHID_Utilities_Source
+hidio_LDADD += HID_Utilities_Source/libHIDUtilities.a
+hidio_LDFLAGS += -bundle -undefined dynamic_lookup \
+ -framework Carbon -framework IOKit -framework ForceFeedback
+endif
+
+if LINUX
+hidio_SOURCES += hidio_linux.c input_arrays.c
+endif
+
+if WINDOWS
+hidio_SOURCES += hidio_windows.c
+endif
+
+
+
+# files that are included but not built
+EXTRA_DIST = COPYING README TODO
+
+# subdirs that are built
+SUBDIRS = $(EXTRA_SUBDIRS)
+
+# subdirs that are always included in the dist, etc.
+DIST_SUBDIRS = HID_Utilities_Source
+