aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-01-28 01:05:06 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-01-28 01:05:06 +0000
commit09cd7db47591a4289dd4ff07cc516b0ec95b62a0 (patch)
tree2ca425700cf1c97a487ed0ad31559c83dc8aaa4d /Makefile.am
parent6b2aa4a4a7816d604ee63c974131c03fed9a4b7c (diff)
streamlined autotools build to be the minimum needed
svn path=/trunk/externals/io/hidio/; revision=13108
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 10 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index ca00a6f..42fd1d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,33 +1,30 @@
AUTOMAKE_OPTIONS = foreign
-noinst_PROGRAMS = hidio
-hidio_SOURCES = hidio.c hidio_types.c
-hidio_CFLAGS = $(CFLAGS)
-hidio_LDADD =
-hidio_LDFLAGS = $(LDFLAGS)
+noinst_PROGRAMS = hidio.@EXTENSION@
+SOURCES = hidio.c hidio_types.c
+LDADD =
+
noinst_HEADERS = hidio.h input_arrays.h
EXTRA_SUBDIRS =
if MACOSX
-hidio_SOURCES += hidio_darwin.c
+SOURCES += hidio_darwin.c
EXTRA_SUBDIRS += HID_Utilities_Source
-hidio_CFLAGS += -IHID_Utilities_Source
-hidio_LDADD += HID_Utilities_Source/libHIDUtilities.a
-hidio_LDFLAGS += -bundle -undefined dynamic_lookup \
+LDADD += HID_Utilities_Source/libHIDUtilities.a
+CFLAGS += -IHID_Utilities_Source
+LDFLAGS += -bundle -undefined dynamic_lookup \
-framework Carbon -framework IOKit -framework ForceFeedback
endif
if LINUX
-hidio_SOURCES += hidio_linux.c input_arrays.c
+SOURCES += hidio_linux.c input_arrays.c
endif
if WINDOWS
-hidio_SOURCES += hidio_windows.c
+SOURCES += hidio_windows.c
endif
-
-
# files that are included but not built
EXTRA_DIST = COPYING README TODO