aboutsummaryrefslogtreecommitdiff
path: root/gfsm/gfsm/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gfsm/gfsm/doc/Makefile.am')
-rw-r--r--gfsm/gfsm/doc/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/gfsm/gfsm/doc/Makefile.am b/gfsm/gfsm/doc/Makefile.am
new file mode 100644
index 0000000..d41ba6f
--- /dev/null
+++ b/gfsm/gfsm/doc/Makefile.am
@@ -0,0 +1,56 @@
+## File: doc/Makefile.am
+## Package: gfsm
+## Description:
+## + automake file for doc/ subdir
+##
+## Process this file with Automake to create Makefile.in.
+##-----------------------------------------------------------------------
+
+##-----------------------------------------------------------------------
+## Primaries: headers
+##-----------------------------------------------------------------------
+
+## --- recursion subdirectories
+SUBDIRS = libgfsm programs
+
+#-----------------------------------------------------------------------
+# Variables: cleanup
+#-----------------------------------------------------------------------
+
+## --- mostlyclean: built by 'make' & commonly rebuilt
+#MOSTLYCLEANFILES =
+
+## --- clean: built by 'make'
+#CLEANFILES =
+
+## --- distclean: built by 'configure'
+#DISTCLEANFILES =
+
+## -- maintainerclean: built by maintainer / by hand
+MAINTAINERCLEANFILES = *~ .*~ Makefile Makefile.in
+
+#-----------------------------------------------------------------------
+# Variables: (un)install
+#-----------------------------------------------------------------------
+pkgdoc_UNINSTALL_FILES = libgfsm programs README.txt
+uninstall-local:
+ for f in $(pkgdoc_UNINSTALL_FILES) ; do \
+ rm -rf $(DESTDIR)$(pkgdocdir)/$$f ;\
+ done
+
+#-----------------------------------------------------------------------
+# Variables: distribution
+#-----------------------------------------------------------------------
+
+## --- extra distribution files
+#EXTRA_DIST = $(man_MANS) $(pkgdata_DATA)
+
+## --- recursion subdirectories for 'make dist'
+#DIST_SUBDIRS =
+
+#-----------------------------------------------------------------------
+# Rules: cleanup
+#-----------------------------------------------------------------------
+.PHONY: cvsclean
+
+cvsclean: maintainer-clean ;