aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-08-21 23:45:40 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-08-21 23:45:40 +0000
commit05681548ba7824da0acab9b7c92133b75d5f25a0 (patch)
tree5d4a6d51f7f2f6a5ae5373e225dcc7bceecf1ee2 /debian/rules
parent0e1bfaa5cddccb6b5e8b3fc7cc538249910a81b6 (diff)
debianized using library template 1.0.1
svn path=/trunk/abstractions/nusmuk/; revision=13885
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..14714fa
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = nusmuk
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+