aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-13 03:06:21 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-13 03:06:21 +0000
commit68b7a63e3befd81e256e38d05b7f36bbd374e8c0 (patch)
treea540e8508fbe7720637250644134e636ee674369 /debian/rules
parent5c120425ea6e9cfb24c5b78b9d9cda7e35cdc898 (diff)
updated to newest Makefile template and debianized
svn path=/trunk/externals/hcs/pan/; revision=13522
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..28401a4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = pan
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+