aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
authorIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2006-11-03 08:42:21 +0000
committerIOhannes m zmölnig <zmoelnig@users.sourceforge.net>2006-11-03 08:42:21 +0000
commit1d031e4e72cfd43eee1bebd1c27e2ce29d21da1b (patch)
tree67fb540ac0bae73d52b83c686cbaa36a30c77369 /src/configure.ac
parente50b7f69cca0265f673b9fbeeda4758cd9cab101 (diff)
...
svn path=/trunk/externals/zexy/; revision=6218
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 3696e1d..16ae801 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -23,6 +23,13 @@ AC_SUBST(PDLIBDIR)
AC_SUBST(INCLUDES)
AC_SUBST(SOURCES)
AC_SUBST(LIBNAME)
+AC_SUBST(CONFIGUREFLAGS)
+
+## store the flags passed to us
+## is there no way to get the flags without quotes?
+#CONFIGUREFLAGS=${ac_configure_args}
+## and is this solution portable? time will show....
+CONFIGUREFLAGS=$(echo ${ac_configure_args} | sed "s/'//g")
AC_ARG_WITH(pdversion,[ --with-pdversion=<ver> enforce a certain pd-version (e.g. 0.37)])
AC_ARG_WITH(version, [ --with-version=<ver> enforce a certain zexy-version (e.g. 2.0)])