aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-09-07 16:57:22 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-09-07 16:57:22 +0000
commit4b44403aebf7f8111f755ab622535e7a8bd7790b (patch)
tree16edd83aa9e3a0f133a3f86c9ee01fec7d4283c5 /debian/rules
reorganized libdir loader into its own folder based on the Makefile library templatesvn2git-root
svn path=/trunk/externals/loaders/libdir/; revision=13981
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3c49f8e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = libdir
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh --with quilt $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+
+override_dh_strip:
+ strip --remove-section=.comment --remove-section=.note --strip-unneeded \
+ $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux