aboutsummaryrefslogtreecommitdiff
path: root/externals/grill/flext/configure.ac
diff options
context:
space:
mode:
authorThomas Grill <xovo@users.sourceforge.net>2005-01-06 04:59:21 +0000
committerThomas Grill <xovo@users.sourceforge.net>2005-01-06 04:59:21 +0000
commited4ce25dc69fd6361f7655a3ab5d05186754316c (patch)
tree39f14a7ccb5116b0368a921944469f747e95c1d0 /externals/grill/flext/configure.ac
parentaeb9247272c2772c491df8f682aebf0097c98519 (diff)
build system for flext-based externals
reconsidered flext::buffer:Update improved buffer handling added object construction and destruction flags updated autoconf system updated documentation updated build system svn path=/trunk/; revision=2467
Diffstat (limited to 'externals/grill/flext/configure.ac')
-rwxr-xr-xexternals/grill/flext/configure.ac21
1 files changed, 12 insertions, 9 deletions
diff --git a/externals/grill/flext/configure.ac b/externals/grill/flext/configure.ac
index bd811b23..83c6e309 100755
--- a/externals/grill/flext/configure.ac
+++ b/externals/grill/flext/configure.ac
@@ -7,7 +7,7 @@ dnl flext API version (current:release:age)
API_VERSION=0:0:0
AC_INIT([flext],[0.5.0],[gr@grrrr.org],[flext])
-AM_INIT_AUTOMAKE(1.8)
+AM_INIT_AUTOMAKE(1.6)
dnl configure options
@@ -70,10 +70,10 @@ AC_ARG_ENABLE(optimize, [ --enable-optimize enables optimized builds for:
OPT_FLAGS="-mtune=$enableval -march=$enableval -mmmx -msse -msse2 -mfpmath=sse";
AC_DEFINE(FLEXT_USE_SIMD);;
G5 | G4)
- OPT_FLAGS="-mtune=$enableval -march=$enableval -maltivec -faltivec -malign-natural";
+ OPT_FLAGS="-mtune=$enableval --maltivec -faltivec -malign-natural";
AC_DEFINE(FLEXT_USE_SIMD);;
G3)
- OPT_FLAGS="-mtune=$enableval -march=$enableval -malign-natural";;
+ OPT_FLAGS="-mtune=$enableval --malign-natural";;
*)
;;
esac
@@ -101,21 +101,23 @@ dnl Checks for library functions.
dnl system specific
if test `uname -s` == Linux; then
- DYNAMIC_LDFLAGS="-Wl,-Bdynamic"
+ DYNAMIC_LDFLAGS="-Wl,-Bdynamic -shared"
EXTENSION=pd_linux
SOEXT=so
fi
if test `uname -s` == Darwin; then
- DYNAMIC_LDFLAGS = "-version-info $API_VERSION -release $AC_PACKAGE_VERSION -dylib -dynamic -flat_namespace -undefined suppress"
+# DYNAMIC_LDFLAGS="-version-info $API_VERSION -release $AC_PACKAGE_VERSION -dynamiclib -dynamic -flat_namespace -undefined suppress"
- if test $system = max; then
- echo "what's the name in max???" #EXEEXT = ???
+ DYNAMIC_LDFLAGS="-dynamiclib -dynamic -flat_namespace -undefined suppress"
+ if test $system == max; then
+ EXTENSION=mxo
else
EXTENSION=pd_darwin
- SOEXT=dylib
- FRAMEWORKS=???
fi
+
+ SOEXT=dylib
+ FRAMEWORKS="ApplicationServices vecLib"
fi
dnl todo: mingw / cygwin
@@ -155,3 +157,4 @@ AC_OUTPUT([
tutorial/pd/Makefile
tutorial/maxmsp/Makefile
source/Makefile])
+