aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-09-28 03:52:47 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-09-28 03:52:47 +0000
commit0cb7959f82c47f9d505d48d6e27641116b8a150d (patch)
treea25aedda29a6595682b1658eccd2ed8a835b9e88 /packages/Makefile.buildlayout
parent8bf2c6f429657e5806f06242fb6eb5658ef39d1d (diff)
Makefile tune ups and clean ups, hopefully to allow things to build faster, especially when using make -j
svn path=/trunk/; revision=6040
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout26
1 files changed, 12 insertions, 14 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index 6c5af58c..802c244e 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -40,20 +40,18 @@ UNAME := $(shell uname -s)
ifeq ($(UNAME),Linux)
OS_NAME = linux
EXTENSION = pd_linux
-else
- ifeq ($(UNAME),Darwin)
- OS_NAME = darwin
- EXTENSION = pd_darwin
- else
- ifeq (MINGW,$(findstring MINGW,$(UNAME)))
- OS_NAME = windows
- EXTENSION = dll
- else
- OS_NAME = unknown
- EXTENSION = so
- $(warning WARNING: unknown environment "$(UNAME)".)
- endif
- endif
+endif
+ifeq ($(UNAME),Darwin)
+ OS_NAME = darwin
+ EXTENSION = pd_darwin
+endif
+ifeq (MINGW,$(findstring MINGW,$(UNAME)))
+ OS_NAME = windows
+ EXTENSION = dll
+endif
+ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
+ OS_NAME = windows
+ EXTENSION = dll
endif
#==============================================================================#