aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile.buildlayout
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-07-21 00:22:52 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-07-21 00:22:52 +0000
commit4a4e4e0747175848f1a51b20e472334c1e8f052d (patch)
tree6846303f888be1fc1338c59902271ba7e3f951a9 /packages/Makefile.buildlayout
parent6768962545c5e0060cb2974453736a9a83c9ba12 (diff)
more work on centralizing the CPU optimization flags. With GNU/Linux on PowerPC and Mac OS X on Intel, things are becoming more complicated... ;)
svn path=/trunk/; revision=5389
Diffstat (limited to 'packages/Makefile.buildlayout')
-rw-r--r--packages/Makefile.buildlayout11
1 files changed, 11 insertions, 0 deletions
diff --git a/packages/Makefile.buildlayout b/packages/Makefile.buildlayout
index 27fb3f6b..d80264b8 100644
--- a/packages/Makefile.buildlayout
+++ b/packages/Makefile.buildlayout
@@ -58,6 +58,17 @@ endif
#==============================================================================#
#
+## CFLAGS
+#
+#==============================================================================#
+
+# base level optimizations
+OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer
+
+DEBUG_CFLAGS = -ggdb
+
+#==============================================================================#
+#
# DIRECTORY STRUCTURE
#
#==============================================================================#