aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-12-20 00:13:17 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-12-20 00:13:17 +0000
commite22199f9828597e0e602be092622a9e8bb8348d7 (patch)
treeb3e9ed35211342d5d051472e8d7237f52a77569f /packages/Makefile
parent0236f3de2940b0047c6135718dcc77251bd91354 (diff)
added in mingw_fixes patch which includes NT2_MSC_VER and lots of other stuff so that everything can compile using MinGW; reorged things to use the full name 'windows' rather than just 'win'. This matches 'darwin' and 'linux'; this is windows RC6
svn path=/trunk/; revision=4260
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 7d004797..b787ff77 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -141,7 +141,7 @@ gem:
#------------------------------------------------------------------------------
# pd
-ifeq ($(OS_NAME),win)
+ifeq ($(OS_NAME),windows)
PD_CONFIGURE_FLAGS =
else
PD_CONFIGURE_FLAGS = --enable-jack
@@ -374,7 +374,9 @@ noncvs_install:
-install -p $(packages_src)/noncvs/$(OS_NAME)/doc/5.reference/*.* \
$(helpdir)
-install -p $(packages_src)/noncvs/$(OS_NAME)/extra/*.* $(objectsdir)
-
+ -install -d $(DESTDIR)$(prefix)/gripd
+ -install -p $(packages_src)/noncvs/$(OS_NAME)/gripd/*.* \
+ $(DESTDIR)$(prefix)/gripd
#------------------------------------------------------------------------------
@@ -533,7 +535,7 @@ devsymlinks: devsymlinks_$(OS_NAME)
-devsymlinks_win:
+devsymlinks_windows:
devsymlinks_linux:
@@ -630,7 +632,7 @@ patch_pd:
cd $(pd_src)/src/ && \
sed 's/\(pd_version\[\] = "Pd version \)[0-9extndRC.-]*/\1$(PD_VERSION)-$(PACKAGE_VERSION)/' s_main.c > s_main.c.tmp && \
mv s_main.c.tmp s_main.c
- for file in $(wildcard *.[ch]); do \
+ for file in $(wildcard $(pd_src)/src/*.[ch]); do \
sed 's/MACOSX/__APPLE__/g' $${file} > $${file}.tmp && \
mv -f $${file}.tmp $$file;\
done
@@ -639,7 +641,7 @@ patch_pd:
unpatch_pd:
- for file in $(wildcard *.[ch]); do \
+ for file in $(wildcard $(pd_src)/src/*.[ch]); do \
sed 's/__APPLE__/MACOSX/g' $${file} > $${file}.tmp && \
mv -f $${file}.tmp $$file;\
done