aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-28 06:46:18 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-28 06:46:18 +0000
commit030d2eec4fd115d8fa54c32873095420ce30ccad (patch)
treeaaf158eb959a1e1e8f641e2e324d238d3fb04c3f /packages/win32_inno
parent450695869e334f4626e08c53e429501d61b11e18 (diff)
- finally got a Linux Pd-extended release out, RC5
- built a tar.bz2 package maker with a generated Makefile for installing and uninstalling - switched all Makefiles to follow GNU $(DESTDIR)/$(prefix) standards svn path=/trunk/; revision=4064
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index 192aa52d..c2919e70 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -5,7 +5,7 @@ all: install
CWD := $(shell pwd)
-prefix = $(CWD)/build
+DESTDIR = $(CWD)/build
cvs_root_dir = $(CWD)/../..
BUILDLAYOUT_DIR = $(CWD)/..
@@ -17,6 +17,7 @@ include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
# output to the same directory tree
DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
cvs_root_dir=$(cvs_root_dir) \
+ DESTDIR=$(DESTDIR) \
prefix=$(prefix) \
UNAME=$(UNAME)
@@ -26,7 +27,7 @@ PD_INNO_SETUP = pd-inno.iss
install: $(PD_INNO_SETUP)
cd $(packages_src) && make $(DEST_PATHS) extended_install
cd .. && make $(DEST_PATHS) doc_format
- install -p pd-settings.reg $(prefix)
+ install -p pd-settings.reg $(DESTDIR)$(prefix)
@echo " "
@echo "win32_inno install succeeded!"
@@ -39,7 +40,7 @@ install: $(PD_INNO_SETUP)
# since I can't get Pd to compile, here are some hacks to assemble a package
# from binaries
no_compile_hacks:
- cp -a /c/Program\ Files/pd-0.38-4 $(prefix)/
+ cp -a /c/Program\ Files/pd-0.38-4 $(DESTDIR)$(prefix)/
$(PD_INNO_SETUP): $(PD_INNO_SETUP).in
@echo "Making Inno Setup file: $(PD_INNO_SETUP)"