aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-12-20 00:13:17 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-12-20 00:13:17 +0000
commite22199f9828597e0e602be092622a9e8bb8348d7 (patch)
treeb3e9ed35211342d5d051472e8d7237f52a77569f /packages/win32_inno
parent0236f3de2940b0047c6135718dcc77251bd91354 (diff)
added in mingw_fixes patch which includes NT2_MSC_VER and lots of other stuff so that everything can compile using MinGW; reorged things to use the full name 'windows' rather than just 'win'. This matches 'darwin' and 'linux'; this is windows RC6
svn path=/trunk/; revision=4260
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile64
-rw-r--r--packages/win32_inno/TODO10
-rwxr-xr-xpackages/win32_inno/pd-inno.iss.in10
-rwxr-xr-xpackages/win32_inno/pd-settings.reg38
4 files changed, 82 insertions, 40 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index 204b83a7..729d603a 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -16,7 +16,7 @@ include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer
# Generic x86 (tune for Pentium III, since that's most common these days)
-OPT_CFLAGS += -march=pentium-mmx -mtune=pentium3 -mmmx
+OPT_CFLAGS += -mcpu=i586 -mtune=pentium3
# INTEL
#
@@ -53,21 +53,65 @@ package: $(PD_INNO_SETUP)
@echo " "
@echo "win32_inno install succeeded!"
-install:
- cd $(packages_src) && make $(DEST_PATHS) extended_install
- cd .. && make $(DEST_PATHS) doc_format
- install -p pd-settings.reg $(DESTDIR)$(prefix)
+# makefile.mingw is available from here:
+# http://sourceforge.net/tracker/index.php?func=detail&aid=1374659&group_id=55736&atid=478072
+build_pd:
+ make -C $(pd_src)/src -f makefile.mingw $(DEST_PATHS)
+
+pd_install: build_pd
+# the autoconf/MinGW setup doesn't compile the extras yet
+# make -C $(pd_src)/src $(DEST_PATHS) bin
+# -make -C $(pd_src)/src $(DEST_PATHS) install
+ make -C $(pd_src)/src -f makefile.mingw $(DEST_PATHS) install
+
+install: pd_install prebuilt_install lib_install exe_install
@echo " "
@echo "win32_inno install succeeded!"
+
+prebuilt_install:
+ make -C $(packages_src) $(DEST_PATHS) extended_install
+ make -C $(packages_src) $(DEST_PATHS) doc_format
+ install -p pd-settings.reg $(DESTDIR)$(prefix)
+
#==============================================================================#
#
-## CVS SOURCES
+## setup Pd binaries
#
#==============================================================================#
-# since I can't get Pd to compile, here are some hacks to assemble a package
-# from binaries
+bin_src = /usr/local/bin
+# ultimately, the DLLs should be installed in %SystemRoot%\system32 by InnoSetup
+#dlldir = $(DESTDIR)$(prefix)/
+dlldir = $(bindir)
+lib_install:
+# these get installed into %SystemRoot%\system32 by the installer
+ install -d $(dlldir)
+ install -p $(bin_src)/libogg-0.dll $(dlldir)/libogg-0.dll
+ install -p $(bin_src)/libsndfile-1.dll $(dlldir)/libsndfile-1.dll
+ install -p $(bin_src)/libvorbis-0.dll $(dlldir)/libvorbis-0.dll
+ install -p $(bin_src)/libvorbisenc-2.dll $(dlldir)/libvorbisenc-2.dll
+ install -p $(bin_src)/libvorbisfile-3.dll $(dlldir)/libvorbisfile-3.dll
+ install -p $(bin_src)/pthreadGC2.dll $(dlldir)/pthreadGC2.dll
+ install -p $(bin_src)/tcl84.dll $(dlldir)/tcl84.dll
+ install -p $(bin_src)/tclpip84.dll $(dlldir)/tclpip84.dll
+ install -p $(bin_src)/tk84.dll $(dlldir)/tk84.dll
+# this is a quick hack, since the gripd.dll still looks for pthreadVC.dll
+ install -p $(DESTDIR)$(prefix)/gripd/pthreadVC.dll $(dlldir)/pthreadVC.dll
+# these go into the Pd package's lib dir
+ install -d $(libdir)/tcl8.4
+ cp -r /usr/local/lib/tcl8.4/* $(libdir)/tcl8.4
+ install -d $(libdir)/tk8.4
+ cp -r /usr/local/lib/tk8.4/* $(libdir)/tk8.4
+
+
+exe_install:
+ install -d $(bindir)
+ install -p $(bin_src)/wish84.exe $(bindir)
+ install -p $(bin_src)/tclsh84.exe $(bindir)
+
+
+# here are some hacks to assemble a package from binaries
no_compile_hacks:
cp -a /c/Program\ Files/pd-0.38-4 $(DESTDIR)$(prefix)/
@@ -80,6 +124,7 @@ $(PD_INNO_SETUP): $(PD_INNO_SETUP).in
$(PD_INNO_SETUP)
# start $(PD_INNO_SETUP)
+
#==============================================================================#
#
## CVS SOURCES
@@ -113,3 +158,6 @@ test_locations:
@echo "HELPDIR $(helpdir)"
@echo "MANUALSDIR $(manualsdir)"
@echo "EXAMPLESDIR $(examplesdir)"
+
+
+.PHONY: all install package clean distclean test_locations dll_install exe_install
diff --git a/packages/win32_inno/TODO b/packages/win32_inno/TODO
index 312ade3c..b2a2dce2 100644
--- a/packages/win32_inno/TODO
+++ b/packages/win32_inno/TODO
@@ -6,17 +6,9 @@
- Another detail is that the menu item "help/1 manual" results in no action -
possibly some link pointing to the wrong place? It turns out that the
rundll "open" thingy isn't working...
- - make Pd.exe using MinGW's "start.exe" like MacOSX's "open"
+ - make Pd.exe using MSYS's "start.exe" like MacOSX's "open"
- menu_openhtml on Win32 with rundll should be able to open other
filetypes like open on MACOSX.
-- get Pd compiling on MinGW:. From Carmen:
-
- - "theres a SConscript in devel_0_39 and theres also a makefile.mingw maybe
- in devel_0_38. just ./configure && make && make install the deps like tk
- and such first, although you can use a static path to MSVC-generated .libs
- if you dont feel like doing that.."
-
-
- get Windows Makefiles for Gem
diff --git a/packages/win32_inno/pd-inno.iss.in b/packages/win32_inno/pd-inno.iss.in
index b0fad843..e6230779 100755
--- a/packages/win32_inno/pd-inno.iss.in
+++ b/packages/win32_inno/pd-inno.iss.in
@@ -103,12 +103,14 @@ Source: build\bin\cyclist.exe; DestDir: {sys}; Flags: confirmoverwrite promptifo
Source: build\doc\manuals\Pd\Welcome.html; DestDir: {app}; Flags: isreadme; Tasks:
Source: build\doc\manuals\Pd\ReadMe.html; DestDir: {app}; Flags: isreadme
Source: build\doc\manuals\Pd\License.html; DestDir: {app}; Flags: isreadme
-Source: build\doc\manuals\Pd\PD LICENSE.txt; DestDir: {app}; Flags: isreadme
+Source: build\doc\manuals\Pd\Pd-LICENSE.txt; DestDir: {app}; Flags: isreadme
Source: build\pd-settings.reg; DestDir: {app}; Flags: ignoreversion
Source: build\bin\*.*; DestDir: {app}\bin; Flags: ignoreversion confirmoverwrite recursesubdirs uninsremovereadonly
Source: build\doc\*.*; DestDir: {app}\doc; Flags: ignoreversion confirmoverwrite recursesubdirs uninsremovereadonly; Attribs: readonly
Source: build\extra\*.*; DestDir: {app}\extra; Flags: ignoreversion recursesubdirs uninsremovereadonly promptifolder; Attribs: readonly
Source: build\lib\*.*; DestDir: {app}\lib; Flags: ignoreversion recursesubdirs
-Source: build\portaudio\*.*; DestDir: {app}\portaudio; Flags: ignoreversion recursesubdirs
-Source: build\src\*.*; DestDir: {app}\src; Flags: ignoreversion recursesubdirs
-Source: build\tcl\*.*; DestDir: {app}\tcl; Flags: ignoreversion recursesubdirs
+Source: build\gripd\*.*; DestDir: {app}\gripd; Flags: ignoreversion
+;; build stuff is not included now
+;Source: build\portaudio\*.*; DestDir: {app}\portaudio; Flags: ignoreversion recursesubdirs
+;Source: build\src\*.*; DestDir: {app}\src; Flags: ignoreversion recursesubdirs
+;Source: build\tcl\*.*; DestDir: {app}\tcl; Flags: ignoreversion recursesubdirs
diff --git a/packages/win32_inno/pd-settings.reg b/packages/win32_inno/pd-settings.reg
index a0911862..9a135142 100755
--- a/packages/win32_inno/pd-settings.reg
+++ b/packages/win32_inno/pd-settings.reg
@@ -1,28 +1,28 @@
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Pd]
-"path1"="c:/progra~1/pd/extra/cyclone"
-"path2"="c:/progra~1/pd/extra/zexy"
-"path3"="c:/progra~1/pd/extra/iemabs"
-"path4"="c:/progra~1/pd/extra/iemmatrix"
-"path5"="c:/progra~1/pd/extra/ix"
-"path6"="c:/progra~1/pd/extra/memento"
-"path7"="c:/progra~1/pd/extra/markex"
-"path8"="c:/progra~1/pd/extra/mjlib"
-"path9"="c:/progra~1/pd/extra/motex"
-"path10"="c:/progra~1/pd/extra/rradical"
-"path11"="c:/progra~1/pd/extra/pixelTANGO"
-"path12"="c:/progra~1/pd/extra/smlib"
-"path13"="c:/progra~1/pd/extra/toxy"
-"path14"="c:/progra~1/pd/extra/unauthorized"
-"path15"="c:/progra~1/pd/extra/creb"
-"path16"="c:/progra~1/pd/extra/maxlib"
-"loadlib1"="dyn~"
-"loadlib2"="gem"
+"loadlib1"="cyclone"
+"loadlib2"="maxlib"
"loadlib3"="gripd"
"loadlib4"="OSC"
"loadlib5"="pmpd"
"loadlib6"="vasp"
"loadlib7"="wmangle"
"loadlib8"="xsample"
-
+"loadlib9"="dyn~"
+"loadlib10"="Gem"
+"loadlib11"="oscx"
+"loadlib12"="zexy"
+"loadlib13"="iemabs"
+"loadlib14"="iemmatrix"
+"loadlib15"="ix"
+"loadlib16"="memento"
+"loadlib17"="markex"
+"loadlib18"="mjlib"
+"loadlib19"="motex"
+"loadlib20"="rradical"
+"loadlib21"="pixelTANGO"
+"loadlib22"="smlib"
+"loadlib23"="toxy"
+"loadlib24"="unauthorized"
+"loadlib25"="creb"