aboutsummaryrefslogtreecommitdiff
path: root/desiredata/src/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'desiredata/src/configure.in')
-rw-r--r--desiredata/src/configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/desiredata/src/configure.in b/desiredata/src/configure.in
index 924297c8..256b280f 100644
--- a/desiredata/src/configure.in
+++ b/desiredata/src/configure.in
@@ -73,11 +73,12 @@ MIDISRC="s_midi_none.c"
WLIB=""
STRIP="meuhhhhh"
-OS=$(uname -s)
-dnl OS=MINGW32
+if test "$OS" = ""; then
+ OS=$(uname -s)
+fi
if test $OS = Linux; then
- LDFLAGS="-Wl,-export-dynamic "
+ LDFLAGS="-Wl,--export-dynamic "
EXT=pd_linux
LIBSUFFIX=.so
CPPFLAGS="-DDL_OPEN -DPA_USE_OSS -DUNIX -DUNISTD"
@@ -119,7 +120,7 @@ if test $OS = Darwin; then
fi
if test $(echo $OS | cut -f1 -d_) = CYGWIN; then
- LDFLAGS="-Wl,-export-dynamic "
+ LDFLAGS="-Wl,--export-dynamic "
EXT=dll
LIBSUFFIX=.dll
CPPFLAGS="-DDL_OPEN -DPA_USE_OSS -DUNIX -DUNISTD"