aboutsummaryrefslogtreecommitdiff
path: root/externals/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'externals/debian/rules')
-rwxr-xr-xexternals/debian/rules126
1 files changed, 126 insertions, 0 deletions
diff --git a/externals/debian/rules b/externals/debian/rules
new file mode 100755
index 00000000..c5167f00
--- /dev/null
+++ b/externals/debian/rules
@@ -0,0 +1,126 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatibility version to use.
+export DH_COMPAT=3
+
+
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ # Build the common externals
+
+ (cd build/linux; $(MAKE))
+
+ # Build zexy
+
+ (cd zexy/src; $(MAKE) -f makefile.linux)
+
+ # Build flext
+
+ (cd grill/flext; $(MAKE) -f makefile.pd-linux)
+
+ # OSC
+
+ (cd OSCx/libOSC;$(MAKE))
+ (cd OSCx/OSC; $(MAKE))
+
+ #/usr/bin/docbook-to-man debian/pd-externals.sgml > pd-externals.1
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -(cd build/linux;$(MAKE) clean)
+
+ (cd zexy/src; $(MAKE) -f makefile.linux clean)
+
+ (cd grill/flext; $(MAKE) -f makefile.pd-linux clean)
+
+ (cd OSCx/libOSC;$(MAKE) clean)
+ (cd OSCx/OSC; $(MAKE) pd_linux_clean)
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/pd-externals.
+ (cd build/linux; $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp)
+ (cd zexy/src; $(MAKE) -f makefile.linux install DESTDIR=$(CURDIR)/debian/tmp \
+ INSTALL_PREFIX=/usr/ \
+ PDLIBDIR=lib/pd )
+ (cd grill/flext; $(MAKE) -f makefile.pd-linux install INSTDIR=$(CURDIR)/debian/tmp/usr/lib/pd/flext)
+
+ # Install OSC
+
+ install OSCx/OSC/OSC.pd_linux $(CURDIR)/debian/tmp/usr/lib/pd/extra
+ install OSCx/doc/*.pd $(CURDIR)/debian/tmp/usr/lib/pd/doc/5.reference
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_movefiles
+# dh_installdebconf
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+ dh_installcron
+ dh_installman
+ dh_installinfo
+# dh_undocumented
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+# dh_perl
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure