aboutsummaryrefslogtreecommitdiff
path: root/externals/grill/flext/tutorial/sndobj1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'externals/grill/flext/tutorial/sndobj1/Makefile.am')
-rw-r--r--externals/grill/flext/tutorial/sndobj1/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/externals/grill/flext/tutorial/sndobj1/Makefile.am b/externals/grill/flext/tutorial/sndobj1/Makefile.am
index eb7ac446..2c9b1436 100644
--- a/externals/grill/flext/tutorial/sndobj1/Makefile.am
+++ b/externals/grill/flext/tutorial/sndobj1/Makefile.am
@@ -8,20 +8,20 @@ NAME = sndobj1
BUILT_SOURCES = main.cpp
EXTRA_DIST = main.cpp \
- $(NAME).cw \
- $(NAME).dsp \
+ $(NAME).mcp \
$(NAME).vcproj
CXXFLAGS = @CXXFLAGS@ \
@OPT_FLAGS@ \
@INCLUDEDIR@ \
-I../../source \
- $(DEFS)
+ $(DEFS) \
+ -DFLEXT_SHARED
LDFLAGS = @LDFLAGS@ \
$(patsubst %,-framework %,$(FRAMEWORKS))
-LIBS = @LIBS@
+LIBS = @LIBS@ -lflext
FRAMEWORKS = @FRAMEWORKS@
@@ -36,9 +36,8 @@ SYSDIR = @SYSDIR@
# ----------------------------- targets --------------------------------
-if SNDOBJ
all-local: $(OBJECTS)
- $(CXX) $(LDFLAGS) -shared ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
+ $(CXX) $(LDFLAGS) ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
strip --strip-unneeded ../$(TARGETDIR)/$(TARGET)
./%.@OBJEXT@ : %.cpp
@@ -50,4 +49,3 @@ clean-local:
install-exec-local:
install ../$(TARGET) $(SYSDIR)extra
-endif \ No newline at end of file