aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile5
-rw-r--r--packages/linux_make/debian/control4
-rw-r--r--packages/linux_make/default.pdsettings24
3 files changed, 16 insertions, 17 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 6b4a2c51..a170f2d3 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -4,7 +4,8 @@
CWD := $(shell pwd)
-DESTDIR = $(CWD)/build
+# DESTDIR needs the trailing slash
+DESTDIR = $(CWD)/build/
cvs_root_dir := $(shell cd $(CWD)/../.. && pwd)
BUILDLAYOUT_DIR = $(cvs_root_dir)/packages
@@ -23,7 +24,7 @@ endif
TARGET_PLATFORM := $(shell uname -m)
ifeq ($(TARGET_PLATFORM),i686)
# Generic x86 (tune for Pentium III, since that's more common these days)
-OPT_CFLAGS += -mcpu=i686 -march=i386
+OPT_CFLAGS += -mtune=i686 -march=i386
#OPT_CFLAGS += -march=pentium3 -msse -mfpmath=sse
#OPT_CFLAGS += -march=pentium4 -msse -msse2 -mfpmath=sse
endif
diff --git a/packages/linux_make/debian/control b/packages/linux_make/debian/control
index 6dc81594..d02855ca 100644
--- a/packages/linux_make/debian/control
+++ b/packages/linux_make/debian/control
@@ -1,5 +1,5 @@
Source: pd-extended
-Version: 0.40.3cvs20080505-1
+Version: 0.40.3extended-1
Section: sound
Priority: optional
Maintainer: Hans-Christoph Steiner <hans@at.or.at>
@@ -9,7 +9,7 @@ Depends: xterm | x-terminal-emulator, ttf-bitstream-vera, x-ttcidfont-conf, tcll
Replaces: puredata, pd-externals, gem, pd-pdp, pd-zexy
Conflicts: pd, pd-externals, gem, pd-pdp, pd-zexy
Provides: pd
-Recommends: liblame0, qjackctl, xdg-utils
+Recommends: qjackctl, xdg-utils
Suggests: xmms
Description: Pure Data with patches and a large collection of externals
Pd (aka Pure Data) is a real-time graphical programming environment for
diff --git a/packages/linux_make/default.pdsettings b/packages/linux_make/default.pdsettings
index 568e4619..5424e233 100644
--- a/packages/linux_make/default.pdsettings
+++ b/packages/linux_make/default.pdsettings
@@ -1,7 +1,7 @@
standardpath: 1
verbose: 0
defeatrt: 0
-flags: -helppath /usr/share/pd
+flags: -helppath ~/pd -helppath /usr/share/pd
loadlib1: libdir
loadlib2: Gem
loadlib3: cyclone
@@ -32,17 +32,15 @@ loadlib27: freeverb
loadlib28: hcs
loadlib29: jmmmp
loadlib30: ext13
-loadlib31: hardware
-loadlib32: ggee
-loadlib33: iem_anything
-loadlib34: flib
-loadlib35: ekext
-loadlib36: flatspace
-loadlib37: deprecated
-loadlib38: pdp
-loadlib39: pidip
-nloadlib: 39
-path1: ~/pd
-path2: /usr/share/pd
+loadlib31: ggee
+loadlib32: iem_anything
+loadlib33: flib
+loadlib34: ekext
+loadlib35: flatspace
+loadlib36: pdp
+loadlib37: pidip
+nloadlib: 37
+path1: ~/pd-externals
+path2: /usr/local/lib/pd-externals
path3: /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
npath: 3