aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile2
-rw-r--r--packages/linux_make/debian/control2
2 files changed, 2 insertions, 2 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 132ee8bd..1f2aed21 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -16,7 +16,7 @@ include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
ifeq ($(PACKAGE_TYPE),deb)
prefix = /usr
# generates the dependencies for all externals and pd itself
- PACKAGE_DEPENDS := $(shell find $(DESTDIR) \( -name "*.pd_linux" -or -name pd-gui -or -wholename \*bin/pd \) -print0 | xargs -0 dpkg-shlibdeps -O | cut -b1-15 --complement )
+ PACKAGE_DEPENDS := $(shell find $(DESTDIR) \( -name "*.pd_linux" -or -name pd-gui -or -wholename \*bin/pd \) -print0 | xargs -0 dpkg-shlibdeps -O | sed 's|shlibs:Depends=|, |' )
else
prefix = /usr/local
endif
diff --git a/packages/linux_make/debian/control b/packages/linux_make/debian/control
index 32798141..baa7ab53 100644
--- a/packages/linux_make/debian/control
+++ b/packages/linux_make/debian/control
@@ -6,7 +6,7 @@ Maintainer: Hans-Christoph Steiner <hans@at.or.at>
Homepage: http://puredata.info
Package: pd-extended
Architecture: i386
-Depends: xterm | x-terminal-emulator, ttf-bitstream-vera, x-ttcidfont-conf, tcllib,
+Depends: xterm | x-terminal-emulator, ttf-bitstream-vera, x-ttcidfont-conf, tcllib
Replaces: puredata, pd-externals, gem, pd-pdp, pd-zexy
Conflicts: pd, pd-externals, gem, pd-pdp, pd-zexy
Provides: pd