diff options
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-x | packages/win32_inno/Makefile | 34 | ||||
-rwxr-xr-x | packages/win32_inno/generate_inno_files.sh | 30 | ||||
-rwxr-xr-x | packages/win32_inno/pd-inno.iss.in | 54 | ||||
-rwxr-xr-x | packages/win32_inno/pd-settings.reg | 11 |
4 files changed, 57 insertions, 72 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile index 0bd7b558..192aa52d 100755 --- a/packages/win32_inno/Makefile +++ b/packages/win32_inno/Makefile @@ -20,9 +20,15 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \ prefix=$(prefix) \ UNAME=$(UNAME) +PD_INNO_SETUP = pd-inno.iss -install: extended_install +install: $(PD_INNO_SETUP) + cd $(packages_src) && make $(DEST_PATHS) extended_install + cd .. && make $(DEST_PATHS) doc_format + install -p pd-settings.reg $(prefix) + @echo " " + @echo "win32_inno install succeeded!" #==============================================================================# # @@ -30,15 +36,19 @@ install: extended_install # #==============================================================================# -PD_ISS_NAME = pd-inno.iss -$(PD_ISS_NAME): $(PD_ISS_NAME).in - @echo "Making Inno Setup file: $(PD_ISS_NAME)" - cat "$(PD_ISS_NAME).in" | \ +# since I can't get Pd to compile, here are some hacks to assemble a package +# from binaries +no_compile_hacks: + cp -a /c/Program\ Files/pd-0.38-4 $(prefix)/ + +$(PD_INNO_SETUP): $(PD_INNO_SETUP).in + @echo "Making Inno Setup file: $(PD_INNO_SETUP)" + cat "$(PD_INNO_SETUP).in" | \ sed 's/PACKAGE_NAME/$(PACKAGE_NAME)/g' | \ - sed 's/PD_VERSION/$(PD_VERSION)-$(PACKAGE_VERSION)/g' > \ - $(PD_ISS_NAME) - -./generate_inno_files.sh >> $(PD_ISS_NAME) -# start $(PD_ISS_NAME) + sed 's/PD_VERSION/$(PD_VERSION)/g' | \ + sed 's/PACKAGE_VERSION/$(PACKAGE_VERSION)/g' > \ + $(PD_INNO_SETUP) +# start $(PD_INNO_SETUP) #==============================================================================# # @@ -46,6 +56,8 @@ $(PD_ISS_NAME): $(PD_ISS_NAME).in # #==============================================================================# -extended_install: - cd $(packages_src) && make $(DEST_PATHS) install +clean: + rm $(PD_INNO_SETUP) + cd $(packages_src) && make $(DEST_PATHS) clean + diff --git a/packages/win32_inno/generate_inno_files.sh b/packages/win32_inno/generate_inno_files.sh deleted file mode 100755 index 22bd3e91..00000000 --- a/packages/win32_inno/generate_inno_files.sh +++ /dev/null @@ -1,30 +0,0 @@ -#!/bin/sh - -ROOT_DIR=build -#ROOT_DIR="$INSTALL_PREFIX" - -function print_dir() -{ - SED=`echo "sed 's|${ROOT_DIR}/||'"` - source=$1 - dest=`echo $source | eval $SED ` - echo "Source: ${source}/*.*; DestDir: {app}/$dest; Flags: ignoreversion" | \ - sed 's|/|\\|g' -} - -function traverse_tree() -{ - my_dir_root="$1" -# echo "ROOT: $my_dir_root" - FILES=`ls -1d ${my_dir_root}/* | grep -v CVS` - if [ "x$FILES" != "x" ]; then - print_dir "$dir" - for dir in $FILES; do - test -d "$dir" && traverse_tree "$dir" - done - fi -} - - -traverse_tree "${ROOT_DIR}" - diff --git a/packages/win32_inno/pd-inno.iss.in b/packages/win32_inno/pd-inno.iss.in index 3e0afcf7..dc956c23 100755 --- a/packages/win32_inno/pd-inno.iss.in +++ b/packages/win32_inno/pd-inno.iss.in @@ -7,7 +7,7 @@ [Setup]
AppName=pd
-AppVerName=PACKAGE_NAME
+AppVerName=Pd-PD_VERSION-PACKAGE_VERSION
AppPublisher=pure-data.org
AppPublisherURL=http://puredata.org
AppSupportURL=http://puredata.org/community/lists/
@@ -34,12 +34,15 @@ Name: {group}\puredata.org; Filename: {app}\pd.url Name: {group}\Uninstall Pure Data; Filename: {uninstallexe}
Name: {userdesktop}\Pure Data; Filename: {app}\bin\pd.exe; Tasks: desktopicon; IconFilename: {app}\lib\pd.ico; IconIndex: 0; WorkingDir: {app}
Name: {userappdata}\Microsoft\Internet Explorer\Quick Launch\Pure Data; Filename: {app}\bin\pd.exe; Tasks: quicklaunchicon; WorkingDir: {app}; IconFilename: {app}\lib\pd.ico; IconIndex: 0
-
-;Name: {group}\Pure Data (no video); Filename: {app}\pd-novideo.bat; IconFilename: {app}\lib\pd.ico; IconIndex: 0; Tasks: quicklaunchicon desktopicon; WorkingDir: {app}
Name: {group}\Documentation\Pd Manual; Filename: {app}\doc\1.manual\index.htm
Name: {group}\Documentation\Pd Drums Tutorial; Filename: {app}\doc\tutorials\footils\pddrums\pddrums.html
Name: {group}\Documentation\Gem Manual; Filename: {app}\doc\gem\00.manual\index.html
Name: {group}\Documentation\Gem Primer; Filename: {app}\doc\gem\GemPrimer.pdf
+;-----------------------------------------------------------------------------
+; GRIPD
+#ifexist "build\bin\gripd.exe"
+Name: {group}\GrIPD; Filename: {app}\bin\gripd.exe
+#endif
[Run]
@@ -72,25 +75,16 @@ OutputExeFilename=Output\PACKAGE_NAME.exe ; packages\win32_inno
Source: pdpatch.ico; DestDir: {app}\lib
Source: pd.ico; DestDir: {app}\lib
-#ifexist "pd-nolibs.bat"
- Source: pd-nolibs.bat; DestDir: {app}
-#endif
-#ifexist "pd.bat"
- Source: pd.bat; DestDir: {app}
-#endif
-#ifexist "pd-novideo.bat"
- Source: pd-novideo.bat; DestDir: {app}
-#endif
;
;
;-----------------------------------------------------------------------------
; put pdsend and pdreceive in the System dir so that they are in the path
;
-Source: build\bin\pdsend.exe; DestDir: {sys}; Flags: confirmoverwrite
-Source: build\bin\pdreceive.exe; DestDir: {sys}; Flags: confirmoverwrite
+Source: build\bin\pdsend.exe; DestDir: {sys}; Flags: confirmoverwrite promptifolder
+Source: build\bin\pdreceive.exe; DestDir: {sys}; Flags: confirmoverwrite promptifolder
; add Cyclone's cyclist.exe if it is present
#ifexist "build\bin\cyclist.exe"
- Source: build\bin\cyclist.exe; DestDir: {sys}; Flags: confirmoverwrite
+Source: build\bin\cyclist.exe; DestDir: {sys}; Flags: confirmoverwrite promptifolder
#endif
;
;
@@ -104,19 +98,17 @@ Source: build\bin\pdreceive.exe; DestDir: {sys}; Flags: confirmoverwrite ;
;
;-----------------------------------------------------------------------------
-; non CVS files
-;
-#ifexist "noncvs\extra"
-Source: noncvs\extra\*.dll; DestDir: {app}\extra
-#endif
-#ifexist "noncvs\doc\5.reference"
-Source: noncvs\doc\5.reference\*.*; DestDir: {app}\doc\5.reference; Flags:
-ignoreversion
-#endif
-;
-;
-;-----------------------------------------------------------------------------
-; AUTO-GENERATED
-; below this line should be blank since the rest of this file is generated
-; by the packages/win32_inno/Makefile. <hans@at.or.at>
-;
+; build system files
+;
+Source: build\doc\manuals\Pd\Welcome.html; DestDir: {app}; Flags: isreadme; Tasks:
+Source: build\doc\manuals\Pd\ReadMe.html; DestDir: {app}; Flags: isreadme
+Source: build\doc\manuals\Pd\License.html; DestDir: {app}; Flags: isreadme
+Source: build\doc\manuals\Pd\PD LICENSE.txt; DestDir: {app}; Flags: isreadme
+Source: build\pd-settings.reg; DestDir: {app}; Flags: ignoreversion
+Source: build\bin\*.*; DestDir: {app}\bin; Flags: ignoreversion confirmoverwrite recursesubdirs uninsremovereadonly
+Source: build\doc\*.*; DestDir: {app}\doc; Flags: ignoreversion confirmoverwrite recursesubdirs uninsremovereadonly; Attribs: readonly
+Source: build\extra\*.*; DestDir: {app}\extra; Flags: ignoreversion recursesubdirs uninsremovereadonly promptifolder; Attribs: readonly
+Source: build\lib\*.*; DestDir: {app}\lib; Flags: ignoreversion recursesubdirs
+Source: build\portaudio\*.*; DestDir: {app}\portaudio; Flags: ignoreversion recursesubdirs
+Source: build\src\*.*; DestDir: {app}\src; Flags: ignoreversion recursesubdirs
+Source: build\tcl\*.*; DestDir: {app}\tcl; Flags: ignoreversion recursesubdirs
diff --git a/packages/win32_inno/pd-settings.reg b/packages/win32_inno/pd-settings.reg new file mode 100755 index 00000000..2fddf6ba --- /dev/null +++ b/packages/win32_inno/pd-settings.reg @@ -0,0 +1,11 @@ +Windows Registry Editor Version 5.00
+
+[HKEY_LOCAL_MACHINE\SOFTWARE\Pd]
+"path1"="c:/progra~1/pd/extra/cyclone"
+"path2"="c:/progra~1/pd/extra/iemabs"
+"path2"="c:/progra~1/pd/extra/unauthorized"
+"loadlib1"="gem"
+"loadlib2"="pmpd"
+"loadlib3"="vasp"
+"loadlib4"="xsample"
+
|