aboutsummaryrefslogtreecommitdiff
path: root/src/mtx_spherical_harmonics/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/mtx_spherical_harmonics/configure.ac')
-rw-r--r--src/mtx_spherical_harmonics/configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/mtx_spherical_harmonics/configure.ac b/src/mtx_spherical_harmonics/configure.ac
new file mode 100644
index 0000000..a5b9ceb
--- /dev/null
+++ b/src/mtx_spherical_harmonics/configure.ac
@@ -0,0 +1,29 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.61)
+AC_INIT([sh], [0.1], [zotter@iem.at])
+AM_INIT_AUTOMAKE([-Wall])
+AC_CONFIG_SRCDIR([legendre_a.h])
+
+# Checks for programs.
+AC_PROG_CC
+
+AC_PROG_RANLIB
+
+# Checks for libraries.
+# FIXME: Replace `main' with a function in `-lm':
+AC_CHECK_LIB([m], [cos])
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdlib.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([pow])
+
+AC_CONFIG_FILES([Makefile test/Makefile])
+AC_OUTPUT