aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ce5fed0..a812697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,8 +77,8 @@ if test -z "$GCC"; then
esac
else
case $host in
- *86-*-linux*)
- CFLAGS="$CFLAGS -DUNIX -Wall -Wimplicit -Wunused -Wmissing-prototypes -O2"
+ *86*-linux*)
+ CFLAGS="$CFLAGS -DUNIX -Wall -Wimplicit -Wunused -Wmissing-prototypes -O2 -fPIC"
LDFLAGS="-Wl,-export_dynamic -shared"
dnl we could test for bad glibc here, but don't
pd_suffix=pd_linux