aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 0 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 58f1739..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/make -f
-
-LIBRARY_NAME = arraysize
-PACKAGE = pd-$(LIBRARY_NAME)
-pkglibdir = /usr/lib/pd/extra
-
-%:
- dh --with quilt $@
-
-override_dh_auto_install:
- make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
-
-override_dh_shlibdeps:
- dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
- -T$(CURDIR)/debian/$(PACKAGE).substvars
-
-override_dh_strip:
- strip --remove-section=.comment --remove-section=.note --strip-unneeded \
- $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux