aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-01-31 21:02:09 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-01-31 21:02:09 +0000
commitf1063fc40b6d4cd3e3edce1cf621c114274d1867 (patch)
treeb9e33d62072b5b94648da734b833b9e60e42d295 /debian/rules
parentee18e2dca411637a65ac042c760af60ee634ae1e (diff)
first working package, finding libc dep and all
svn path=/trunk/externals/ext13/; revision=13122
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index ded37b7..9c2f3e7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,15 @@
#!/usr/bin/make -f
+
+LIBRARY_NAME = ext13
+PACKAGE = pd-$(LIBRARY_NAME)
+
%:
dh $@
override_dh_auto_install:
- make DESTDIR=$(CURDIR)/debian/tmp pkglibdir=/usr/lib/pd install
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=/usr/lib/pd install
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)/usr/lib/pd/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars