aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index ded37b7..9c2f3e7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,15 @@
#!/usr/bin/make -f
+
+LIBRARY_NAME = ext13
+PACKAGE = pd-$(LIBRARY_NAME)
+
%:
dh $@
override_dh_auto_install:
- make DESTDIR=$(CURDIR)/debian/tmp pkglibdir=/usr/lib/pd install
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=/usr/lib/pd install
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)/usr/lib/pd/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars