aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-10-05 17:59:52 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-10-05 17:59:52 +0000
commit68a80c9c59ea9daf79baa84867f20c4efa1d1e20 (patch)
tree0360669c005a3384845f5564168d7b10bd942176 /debian/rules
parenta67eab4cb0aad864b8a9a89085908955dec9f439 (diff)
debianized fftease
svn path=/trunk/externals/fftease/; revision=16343
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..821eadd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = fftease
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@ --buildsystem=makefile
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir)
+# clean up included example scripts
+ chmod a+x $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/examples/*.pl
+ sed -i 's|/usr/local/bin/perl|/usr/bin/perl|' \
+ $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/examples/*.pl
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars