aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-04-19 00:52:01 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-04-19 00:52:01 +0000
commit7b5865c2a0ebf7a7ebd48039dcc22266552dbb0f (patch)
tree820607880bf9aa7124de3166b90a6c7127f4d759 /configure.ac
parentff89bb0909dd6ba39f79314ae40a89a7b706c63d (diff)
made it search for the sources in the standard Dev layout as well as /usr/local
svn path=/trunk/externals/gem2pdp/; revision=2784
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 26 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f2cb5fd..74cc57a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,9 +2,32 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT
GEM2PDP_VERSION=0.6
-PD_DIR=/usr/local/pd
-PDP_DIR=/usr/local/pd/pdp
-GEM_DIR=/usr/local/pd/gem
+
+if test -f /usr/local/pd; then
+ PD_DIR=/usr/local/pd
+elif test -f ../../pd; then
+ PD_DIR=../../pd
+elif
+ echo "Pd sources not found"
+fi
+
+if test -f /usr/local/pd/pdp; then
+ PDP_DIR=/usr/local/pd/pdp
+elif test -f ../pdp; then
+ PDP_DIR=../pdp
+elif
+ echo "PdP sources not found"
+fi
+
+if test -f /usr/local/pd/gem; then
+ GEM_DIR=/usr/local/pd/gem
+elif test -f ../../Gem; then
+ GEM_DIR=../../Gem
+elif test -f ../gem/Gem; then
+ GEM_DIR=../gem/Gem
+elif
+ echo "Gem sources not found"
+fi
AC_ISC_POSIX
AC_PROG_CC