aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-14 01:10:47 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-14 01:10:47 +0000
commit840d8f335d1e09d94aa09742b1bee5d7f1105b8e (patch)
treef658a3c685351ccfa895a58753f56d5106ceafd5 /debian
parent0b4d71c6fdca20015c590c3765a49f3de8e9a73a (diff)
setup 'hcs' lib with template Makefile and debianized
svn path=/trunk/externals/hcs/; revision=13538
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control12
-rw-r--r--debian/copyright16
-rwxr-xr-xdebian/rules16
5 files changed, 50 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3d1ed26
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-hcs (0.0-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..d3af5e6
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,12 @@
+Source: pd-hcs
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), puredata (>= 0.42.5-3.1~)
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-hcs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description:
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..cfbdbd7
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,16 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Sat, 3 Apr 2010 17:14:25 -0400
+Files: *
+Copyright: 2003-2009, Hans-Christoph Steiner
+ 2007, Free Software Foundation
+ 2006, Fredrik Olofsson
+
+License: GPL-3+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 3 can be found in file "/usr/share/common-licenses/GPL-3".
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ed9ed62
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = hcs
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+