aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-09-05 05:37:29 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-09-05 05:37:29 +0000
commite1acf4b1e24d0a5a16352f49f0791a264c6845d8 (patch)
tree71f327ba01f4aca5dbc05efd72c6ffedc51a8b34 /debian
parent841877ca51e22468984a7d61d6fe933d85c61c1d (diff)
added override_dh_strip target from pd-wiimote to strip things properly
svn path=/trunk/externals/hcs/; revision=13978
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c0bbc01..68c6bf3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,7 +5,7 @@ PACKAGE = pd-$(LIBRARY_NAME)
pkglibdir = /usr/lib/pd/extra
%:
- dh $@
+ dh --with quilt $@
override_dh_auto_install:
make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
@@ -16,3 +16,6 @@ override_dh_shlibdeps:
dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
-T$(CURDIR)/debian/$(PACKAGE).substvars
+override_dh_strip:
+ strip --remove-section=.comment --remove-section=.note --strip-unneeded \
+ $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux