aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-15 22:49:58 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-15 22:49:58 +0000
commit16735a33c59081ed4870f17c3120687a438b5169 (patch)
treefdb3051e68110d3bb0ce7bafa713c63988747e72 /debian
parent524581a56d20213101c97756985a53d5377e261d (diff)
converted to makefile template and debianized
svn path=/trunk/abstractions/jmmmp/; revision=13548
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control12
-rw-r--r--debian/copyright6
-rwxr-xr-xdebian/rules16
5 files changed, 40 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..09fcdd7
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-jmmmp (0.1-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..0c558df
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,12 @@
+Source: pd-jmmmp
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), puredata (>= 0.42.5-3.1~)
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-jmmmp
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description:
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..1310560
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,6 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Sat, 3 Apr 2010 17:14:25 -0400
+Files: *
+Copyright: 2005-2009, João Pais <jmmmpais@googlemail.com>
+
+License:
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b86c464
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = jmmmp
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+