aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-11-22 21:15:30 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-11-22 21:15:30 +0000
commit79bc1e3392cc8b963814a4932892d836550e0baf (patch)
tree3b27b3fa34e88f9cc4066502f7d8ce72b297f031 /debian
parent6b90ede50883f41e5bca89d88a38aa0c7c831244 (diff)
debianized
svn path=/trunk/externals/many/; revision=14491
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control39
-rw-r--r--debian/copyright25
-rw-r--r--debian/gbp.conf7
-rw-r--r--debian/links3
-rwxr-xr-xdebian/rules17
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch2
9 files changed, 100 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3a6ef5d
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-many (0.0-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..cb5cf61
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,39 @@
+Source: pd-many
+Section: sound
+Priority: optional
+Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
+Uploaders: Hans-Christoph Steiner <hans@eds.org>
+Build-Depends: debhelper (>= 7.0.50~),
+ puredata
+Standards-Version: 3.9.1
+Homepage: http://puredata.info
+
+Package: pd-many
+Architecture: all
+Depends: ${shlibs:Depends},
+ pd,
+ pd-ggee,
+ pd-libdir,
+ pd-zexy,
+ ${misc:Depends}
+Recommends: pd-import,
+ pd-pddp
+Description: a Pd library for creating and managing many instances of objects
+ This is a library for of techniques for creating and managing many
+ instances of an object.
+ .
+ * bundle: a bundle of instances all connected to the same
+ inlets and outlets
+ * instances: many instances that are both individually
+ and globally addressable
+ * instances~: same as [instances] but with outlet~s
+ * polypoly~: designed for MIDI polyphony, built upon
+ [poly] and based on [polypoly]
+ * voices~: similar to polypoly~, but for generate voice
+ allocation without being tied to MIDI
+ .
+ Objects in the 'many' lib are based on code from Stephen Pickles'
+ (aka pix) nqpoly4 and Frank Barknecht's polypoly. Thanks to pix's
+ nqpoly4 because that was the real groundbreaking work that proved
+ that a useful and reliable instance-managing object could be
+ programmed in Pd.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..d38aaca
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,25 @@
+Format-Specification: http://svn.debian.org/wsvn/dep/web/deps/dep5.mdwn?rev=135
+Name: many
+Maintainer:
+Source: http://sourceforge.net/projects/pure-data/files/libraries/many/
+
+Files: *
+Copyright: 2001-2003, Steven Pickles
+ 2007, Frank Barknecht
+ 2007-2010, Hans-Christoph Steiner
+License: GPL-3+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+X-Comment: On Debian systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL-2'.
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..ae1dc36
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,7 @@
+[DEFAULT]
+upstream-branch = upstream
+debian-branch = master
+upstream-tag = upstream/%(version)s
+debian-tag = debian/%(version)s
+pristine-tar = True
+sign-tags = True
diff --git a/debian/links b/debian/links
new file mode 100644
index 0000000..48fcdf9
--- /dev/null
+++ b/debian/links
@@ -0,0 +1,3 @@
+usr/lib/pd/extra/many/README.txt usr/share/doc/pd-many/README
+usr/lib/pd/extra/many/examples usr/share/doc/pd-many/examples
+usr/share/common-licenses/GPL-2 usr/lib/pd/extra/many/LICENSE.txt
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e138ba6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = many
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@ --buildsystem=makefile
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir)
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..82c0d1a
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://sf.net/pure-data/template-(.*)\.tar\.gz