aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-10 04:39:52 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-10 04:39:52 +0000
commit9d4ee7c75c8bd4c53600331fd55f2a3680135c3c (patch)
treea450f21545c3063f7fdd19875362c3161a0064dd /debian
parentc67bde56d30140981d831fea3b691b3b508362b6 (diff)
setup mapping lib with template Makefile+debian stuff
svn path=/trunk/externals/mapping/; revision=13164
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control18
-rw-r--r--debian/copyright13
-rwxr-xr-xdebian/rules16
5 files changed, 53 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..bf8b6b1
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-mapping (0.2-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..fc089ea
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,18 @@
+Source: pd-mapping
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~)
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-mapping
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description: library for creatively mapping data
+ The Mapping Library for Pd is a library of mapping primitives for mapping
+ data to controls. Also included are techniques for conditioning sensor data
+ to make it usable in the context of instrument design. It is something like a
+ set of unit generators for mapping, plotting out the most basic building
+ blocks for creating instrument mappings.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..52e118b
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,13 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Tue, 9 Feb 2010 17:14:25 -0400
+Files: *
+Copyright: Copyright 2004-2009 Cyrille Henry and Hans-Christoph Steiner
+
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 2 can be found in file "/usr/share/common-licenses/GPL-2".
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6441f96
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = mapping
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+