aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-20 05:19:22 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-20 05:19:22 +0000
commit9fde407f30007cc47c3cdd48bc221d8a5fe14746 (patch)
treeb6a4d8a74bf3097c1c038a8ef0003c30976f5092 /debian/rules
parent54cab07e41e4b0e4a6a19497343c1edac7c05bf3 (diff)
debianized markex and cleaned up license file stuff
svn path=/trunk/externals/markex/; revision=13179
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c280dec
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = markex
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+