aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules89
1 files changed, 0 insertions, 89 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 98228e3..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# This file is public domain software, originally written by Joey Hess.
-#
-# This version is for packages that are architecture independent.
-
-LIBRARY_NAME = cyclone
-PACKAGE = pd-$(LIBRARY_NAME)
-pkglibdir = /usr/lib/pd/extra
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE) -C cyclone -f Makefile.libdir
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- $(MAKE) -C cyclone -f Makefile.libdir clean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- # Add here commands to install the package into debian/<packagename>.
- $(MAKE) -C cyclone -f Makefile.libdir DESTDIR=$(CURDIR)/debian/$(PACKAGE) \
- prefix=/usr pkglibdir=$(pkglibdir) install
- # remove cyclist until its documented and tested
- rm -f -- $(CURDIR)/debian/$(PACKAGE)/usr/bin/cyclist
- rmdir -- $(CURDIR)/debian/$(PACKAGE)/usr/bin/
-
-
-override_dh_shlibdeps:
- dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
- -T$(CURDIR)/debian/$(PACKAGE).substvars
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installcatalogs
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
-# dh_installwm
-# dh_installudev
- dh_lintian
-# dh_bugfiles
-# dh_undocumented
-# dh_installman
- dh_link
- dh_compress
- dh_fixperms
-# dh_perl
- dh_shlibdeps
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install