aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-21 06:00:49 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-21 06:00:49 +0000
commit972e30e5f3cd2d88fb2de1276cb3c0b0dab8a0de (patch)
tree640f606e9a13b15263ab9a41d51c190e059727f7 /debian
parent35ed8f32edda9e23741fdb6a9fd0c7ebb7ee8b11 (diff)
ported mjlib to template Makefile and debian stuff
svn path=/trunk/externals/mjlib/; revision=13186
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control13
-rw-r--r--debian/copyright13
-rwxr-xr-xdebian/rules16
5 files changed, 48 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..be29cfd
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-mjlib (0.1-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..19fda48
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: pd-mjlib
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), puredata
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-mjlib
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description: library of objects for composing music
+ A library of objects for composing music written by Mark Williamson.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..8fcc4a4
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,13 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Tue, 9 Feb 2010 17:14:25 -0400
+Files: *
+Copyright: 2002-2004, mark williamson <mark@junklight.com>
+
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 2 can be found in file "/usr/share/common-licenses/GPL-2".
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b72f5ac
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = mjlib
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+