aboutsummaryrefslogtreecommitdiff
path: root/hello/Makefile.am
diff options
context:
space:
mode:
authorBryan Jurish <mukau@users.sourceforge.net>2009-02-14 20:34:47 +0000
committerBryan Jurish <mukau@users.sourceforge.net>2009-02-14 20:34:47 +0000
commitc3764252f3c566cdd0f325eac2401378ab92775f (patch)
treeb6b0563c459d192c7b1910b8a591e0c481fbe2c0 /hello/Makefile.am
parent4f69b08833151fab744e64a16ae8016a123fa929 (diff)
+ added hello/ : demonstrate use of autotools utilities for Pd externals
svn path=/trunk/externals/moocow/; revision=10768
Diffstat (limited to 'hello/Makefile.am')
-rw-r--r--hello/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/hello/Makefile.am b/hello/Makefile.am
new file mode 100644
index 0000000..484fe0c
--- /dev/null
+++ b/hello/Makefile.am
@@ -0,0 +1,63 @@
+# File: ./Makefile.am
+# Package: hello
+# Description:
+# + simple automake file for example pd external
+#
+# Process this file with Automake to create Makefile.in.
+#-----------------------------------------------------------------------
+
+##-----------------------------------------------------------------------
+## Options & Subdirectories
+
+##-- aclocal options (top level only)
+ACLOCAL_AMFLAGS = -I m4
+
+## --- automake options (top level only)
+#AUTOMAKE_OPTIONS = foreign dist-bzip2 dist-zip
+AUTOMAKE_OPTIONS = foreign
+
+## --- recursion subdirectories
+#SUBDIRS = config src
+
+#-----------------------------------------------------------------------
+# Includes
+#-----------------------------------------------------------------------
+include $(top_srcdir)/pdexternal.am
+
+##-----------------------------------------------------------------------
+## Pd Externals: hacked _PROGRAMS
+#-----------------------------------------------------------------------
+
+pdexterns_PROGRAMS = hello
+if WANT_OBJECT_EXTERNALS
+ pdexterns_PROGRAMS += goodbye
+endif
+
+##-- possible single-object externals (as _PROGRAMS)
+EXTRA_PROGRAMS = goodbye
+
+##-- sources
+hello_SOURCES = hello.c mooPdUtils.h
+goodbye_SOURCES = goodbye.c mooPdUtils.h
+
+##-- patches
+pdexterns_DATA = heynow.pd
+
+##-- documentation
+pddoc_DATA = \
+ hello-help.pd \
+ goodbye-help.pd
+
+#-----------------------------------------------------------------------
+# Additional Variables & Rules: PODS
+#-----------------------------------------------------------------------
+PODS = README.pod
+
+all-local: $(PODS:.pod=.txt)
+
+##-----------------------------------------------------------------------
+## Variables: distribution
+#-----------------------------------------------------------------------
+
+## --- extra distribution files
+#EXTRA_DIST += $(PODS:.pod=.txt)