aboutsummaryrefslogtreecommitdiff
path: root/deque/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'deque/src/Makefile.am')
-rw-r--r--deque/src/Makefile.am104
1 files changed, 4 insertions, 100 deletions
diff --git a/deque/src/Makefile.am b/deque/src/Makefile.am
index 25d9982..89477af 100644
--- a/deque/src/Makefile.am
+++ b/deque/src/Makefile.am
@@ -7,27 +7,16 @@
#-----------------------------------------------------------------------
#-----------------------------------------------------------------------
-# Options & Subdirectories
+# Includes
#-----------------------------------------------------------------------
-
-## --- recursion subdirectories
-#SUBDIRS =
-
-## --- pseudo-deps for '.SUFFIXES'
-SUFFIXES = .@PDEXT@
-
-#-----------------------------------------------------------------------
-# Flags and variables
-#-----------------------------------------------------------------------
-PDEXT = @PDEXT@
-EXEEXT = .@PDEXT@
+include $(top_srcdir)/pdexternal.am
#-----------------------------------------------------------------------
# pd externals (hacked _PROGRAMS target)
#-----------------------------------------------------------------------
-## --- externals
-pdexterns_PROGRAMS = @PD_OBJECT_EXTERNALS@
+##--- externals
+pdexterns_PROGRAMS = deque
## --- possible externals
EXTRA_PROGRAMS = deque
@@ -38,7 +27,6 @@ pdexterns_DATA =
## --- documentation
pddoc_DATA = deque-help.pd
-
#-----------------------------------------------------------------------
# sources
#-----------------------------------------------------------------------
@@ -48,87 +36,3 @@ deque_SOURCES = \
squeue.c squeue.h \
dsqueue.c dsqueue.h \
deque.c
-
-#-----------------------------------------------------------------------
-# external compilation : flags
-#-----------------------------------------------------------------------
-DEFS = @DEFS@
-AFLAGS = @AFLAGS@
-DFLAGS = @DFLAGS@
-IFLAGS = @IFLAGS@
-LFLAGS = @LFLAGS@
-OFLAGS = @OFLAGS@
-WFLAGS = -Wall -Winline
-
-AM_CPPFLAGS = $(IFLAGS) $(DFLAGS)
-AM_CFLAGS = $(OFLAGS) $(WFLAGS) $(AFLAGS)
-
-deque_LDFLAGS = $(LFLAGS)
-deque_LDADD =
-
-#-----------------------------------------------------------------------
-# Variables: cleanup
-#-----------------------------------------------------------------------
-## --- mostlyclean: built by 'make' & commonly rebuilt
-#MOSTLYCLEANFILES =
-
-## --- clean: built by 'make'
-CLEANFILES = *.$(PDEXT)
-
-## --- distclean: built by 'configure'
-DISTCLEANFILES = \
- config.log \
- config.cache \
- config.status
-
-## -- maintainerclean: built by maintainer / by hand
-MAINTAINERCLEANFILES = *~ \
- $(PODS:.pod=.txt) \
- Makefile Makefile.in \
- aclocal.m4 \
- configure \
- install-sh \
- stamp-h.in \
- config.h.in
-
-maintainer-clean-local:
- rm -rf autom4te.cache
-
-#CVSCLEAN_SUBDIRS = $(SUBDIRS)
-
-#CVSCLEANFILES = Makefile.in Makefile
-
-
-#-----------------------------------------------------------------------
-# Variables: distribution
-#-----------------------------------------------------------------------
-
-## --- extra distribution files
-EXTRA_DIST = \
- $(pddoc_DATA) \
- $(pdexterns_DATA)
-
-## --- recursion subdirectories for 'make dist'
-DIST_SUBDIRS = $(SUBDIRS)
-
-## --- dist-hook: when another 'Makefile.am' is overkill
-#DISTHOOK_DIRS = foo
-#DISTHOOK_FILES = foo/bar.txt foo/baz.txt
-#dist-hook:
-# for d in $(DISTHOOK_DIRS); do\
-# mkdir -p $(distdir)/$$d ;\
-# done
-# for f in $(DISTHOOK_FILES); do\
-# cp -p $(srcdir)/$$f $(distdir)/$$f ;\
-# done
-
-#dist-bz2: dist-bzip2 ;
-
-
-#-----------------------------------------------------------------------
-# Rules: cleanup
-#-----------------------------------------------------------------------
-.PHONY: cvsclean cvsclean-hook
-
-cvsclean: maintainer-clean ;
-