aboutsummaryrefslogtreecommitdiff
path: root/locale/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'locale/src/Makefile.am')
-rw-r--r--locale/src/Makefile.am112
1 files changed, 7 insertions, 105 deletions
diff --git a/locale/src/Makefile.am b/locale/src/Makefile.am
index 8eb938e..3c5829e 100644
--- a/locale/src/Makefile.am
+++ b/locale/src/Makefile.am
@@ -1,37 +1,24 @@
# File: ./src/Makefile.am
-# Package: rawfile
+# Package: (pd external)
# Description:
# + src-level automake file
-#
-# Process this file with Automake to create Makefile.in.
#-----------------------------------------------------------------------
#-----------------------------------------------------------------------
-# Options & Subdirectories
+# Includes
#-----------------------------------------------------------------------
-
-## --- recursion subdirectories
-#SUBDIRS =
-
-## --- pseudo-deps for '.SUFFIXES'
-SUFFIXES = .@PDEXT@
-
-#-----------------------------------------------------------------------
-# Flags and variables
-#-----------------------------------------------------------------------
-PDEXT = @PDEXT@
-EXEEXT = .@PDEXT@
+include $(top_srcdir)/pdexternal.am
#-----------------------------------------------------------------------
# pd externals (hacked _PROGRAMS target)
#-----------------------------------------------------------------------
## --- externals
-pdexterns_PROGRAMS = @PD_OBJECT_EXTERNALS@
+pdexterns_PROGRAMS = locale uselocale
## --- possible externals
EXTRA_PROGRAMS = \
- locale
+ locale uselocale
## --- patches
pdexterns_DATA =
@@ -43,90 +30,5 @@ pddoc_DATA = locale-help.pd
#-----------------------------------------------------------------------
# sources
#-----------------------------------------------------------------------
-
-locale_SOURCES = \
- locale.c
-
-#-----------------------------------------------------------------------
-# external compilation : flags
-#-----------------------------------------------------------------------
-DEFS = @DEFS@
-AFLAGS = @AFLAGS@
-DFLAGS = @DFLAGS@
-IFLAGS = @IFLAGS@
-LFLAGS = @LFLAGS@
-OFLAGS = @OFLAGS@
-WFLAGS = -Wall -Winline
-
-AM_CPPFLAGS = $(IFLAGS) $(DFLAGS)
-AM_CFLAGS = $(OFLAGS) $(WFLAGS) $(AFLAGS)
-
-locale_LDFLAGS = $(LFLAGS)
-#locale_LDADD =
-
-#-----------------------------------------------------------------------
-# Variables: cleanup
-#-----------------------------------------------------------------------
-## --- mostlyclean: built by 'make' & commonly rebuilt
-#MOSTLYCLEANFILES =
-
-## --- clean: built by 'make'
-CLEANFILES = *.$(PDEXT)
-
-## --- distclean: built by 'configure'
-DISTCLEANFILES = \
- config.log \
- config.cache \
- config.status
-
-## -- maintainerclean: built by maintainer / by hand
-MAINTAINERCLEANFILES = *~ \
- $(PODS:.pod=.txt) \
- Makefile Makefile.in \
- aclocal.m4 \
- configure \
- install-sh \
- stamp-h.in \
- config.h.in
-
-maintainer-clean-local:
- rm -rf autom4te.cache
-
-#CVSCLEAN_SUBDIRS = $(SUBDIRS)
-
-#CVSCLEANFILES = Makefile.in Makefile
-
-
-#-----------------------------------------------------------------------
-# Variables: distribution
-#-----------------------------------------------------------------------
-
-## --- extra distribution files
-EXTRA_DIST = \
- $(pddoc_DATA) \
- $(pdexterns_DATA)
-
-## --- recursion subdirectories for 'make dist'
-DIST_SUBDIRS = $(SUBDIRS)
-
-## --- dist-hook: when another 'Makefile.am' is overkill
-#DISTHOOK_DIRS = foo
-#DISTHOOK_FILES = foo/bar.txt foo/baz.txt
-#dist-hook:
-# for d in $(DISTHOOK_DIRS); do\
-# mkdir -p $(distdir)/$$d ;\
-# done
-# for f in $(DISTHOOK_FILES); do\
-# cp -p $(srcdir)/$$f $(distdir)/$$f ;\
-# done
-
-#dist-bz2: dist-bzip2 ;
-
-
-#-----------------------------------------------------------------------
-# Rules: cleanup
-#-----------------------------------------------------------------------
-.PHONY: cvsclean cvsclean-hook
-
-cvsclean: maintainer-clean ;
-
+locale_SOURCES = locale.c
+uselocale_SOURCES = uselocale.c