aboutsummaryrefslogtreecommitdiff
path: root/pdstring+wchar/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pdstring+wchar/src/Makefile.am')
-rw-r--r--pdstring+wchar/src/Makefile.am164
1 files changed, 0 insertions, 164 deletions
diff --git a/pdstring+wchar/src/Makefile.am b/pdstring+wchar/src/Makefile.am
deleted file mode 100644
index 7f8df55..0000000
--- a/pdstring+wchar/src/Makefile.am
+++ /dev/null
@@ -1,164 +0,0 @@
-# File: ./src/Makefile.am
-# Package: pdstring
-# Description:
-# + src-level automake file
-#
-# Process this file with Automake to create Makefile.in.
-#-----------------------------------------------------------------------
-
-#-----------------------------------------------------------------------
-# Options & Subdirectories
-#-----------------------------------------------------------------------
-
-## --- recursion subdirectories
-#SUBDIRS =
-
-## --- pseudo-deps for '.SUFFIXES'
-SUFFIXES = .@PDEXT@
-
-#-----------------------------------------------------------------------
-# Flags and variables
-#-----------------------------------------------------------------------
-PDEXT = @PDEXT@
-EXEEXT = .@PDEXT@
-
-#-----------------------------------------------------------------------
-# pd externals (hacked _PROGRAMS target)
-#-----------------------------------------------------------------------
-
-## --- externals
-pdexterns_PROGRAMS = @PD_OBJECT_EXTERNALS@
-
-## --- possible externals
-EXTRA_PROGRAMS = \
- pdstring \
- any2bytes \
- bytes2any \
- bytes2wchars \
- wchars2bytes
-
-## --- patches
-pdexterns_DATA = \
- any2wchars.pd \
- wchars2any.pd
-
-## --- documentation
-pddoc_DATA = \
- pdstring-help.pd \
- any2bytes-help.pd \
- bytes2any-help.pd \
- bytes2wchars-help.pd \
- wchars2bytes-help.pd \
- any2wchars-help.pd \
- wchars2any-help.pd
-
-
-#-----------------------------------------------------------------------
-# sources
-#-----------------------------------------------------------------------
-
-any2bytes_SOURCES = any2bytes.c mooPdUtils.h pdstringUtils.h
-
-bytes2any_SOURCES = bytes2any.c mooPdUtils.h pdstringUtils.h
-
-bytes2wchars_SOURCES = bytes2wchars.c mooPdUtils.h pdstringUtils.h
-
-wchars2bytes_SOURCES = wchars2bytes.c mooPdUtils.h pdstringUtils.h
-
-pdstring_SOURCES = pdstring.c mooPdUtils.h pdstringUtils.h
-
-pdstring.$(OBJECT): $(any2bytes_SOURCES) $(bytes2any_SOURCES) $(bytes2wchars_SOURCES) $(wchars2bytes_SOURCES)
-
-#-----------------------------------------------------------------------
-# external compilation : flags
-#-----------------------------------------------------------------------
-DEFS = @DEFS@
-AFLAGS = @AFLAGS@
-DFLAGS = @DFLAGS@
-IFLAGS = @IFLAGS@
-LFLAGS = @LFLAGS@
-OFLAGS = @OFLAGS@
-WFLAGS = -Wall -Winline
-
-#GLIB_IFLAGS = @GLIB_IFLAGS@
-#GLIB_LFLAGS = @GLIB_LFLAGS@
-
-AM_CPPFLAGS = $(IFLAGS) $(GLIB_IFLAGS) $(DFLAGS)
-AM_CFLAGS = $(OFLAGS) $(WFLAGS) $(AFLAGS)
-
-pdstring_LDFLAGS = $(LFLAGS)
-
-bytes2any_LDFLAGS = $(LFLAGS)
-
-any2bytes_LDFLAGS = $(LFLAGS)
-
-bytes2wchars_LDFLAGS = $(LFLAGS)
-
-wchars2bytes_LDFLAGS = $(LFLAGS)
-
-#-----------------------------------------------------------------------
-# Variables: cleanup
-#-----------------------------------------------------------------------
-## --- mostlyclean: built by 'make' & commonly rebuilt
-#MOSTLYCLEANFILES =
-
-## --- clean: built by 'make'
-CLEANFILES = *.$(PDEXT)
-
-## --- distclean: built by 'configure'
-DISTCLEANFILES = \
- config.log \
- config.cache \
- config.status
-
-## -- maintainerclean: built by maintainer / by hand
-MAINTAINERCLEANFILES = *~ \
- $(PODS:.pod=.txt) \
- Makefile Makefile.in \
- aclocal.m4 \
- configure \
- install-sh \
- stamp-h.in \
- config.h.in
-
-maintainer-clean-local:
- rm -rf autom4te.cache
-
-#CVSCLEAN_SUBDIRS = $(SUBDIRS)
-
-#CVSCLEANFILES = Makefile.in Makefile
-
-
-#-----------------------------------------------------------------------
-# Variables: distribution
-#-----------------------------------------------------------------------
-
-## --- extra distribution files
-EXTRA_DIST = \
- $(pddoc_DATA) \
- $(pdexterns_DATA)
-
-## --- recursion subdirectories for 'make dist'
-DIST_SUBDIRS = $(SUBDIRS)
-
-## --- dist-hook: when another 'Makefile.am' is overkill
-#DISTHOOK_DIRS = foo
-#DISTHOOK_FILES = foo/bar.txt foo/baz.txt
-#dist-hook:
-# for d in $(DISTHOOK_DIRS); do\
-# mkdir -p $(distdir)/$$d ;\
-# done
-# for f in $(DISTHOOK_FILES); do\
-# cp -p $(srcdir)/$$f $(distdir)/$$f ;\
-# done
-
-#dist-bz2: dist-bzip2 ;
-
-
-#-----------------------------------------------------------------------
-# Rules: cleanup
-#-----------------------------------------------------------------------
-.PHONY: cvsclean cvsclean-hook
-
-cvsclean: maintainer-clean ;
-