aboutsummaryrefslogtreecommitdiff
path: root/readdir/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'readdir/Makefile.am')
-rw-r--r--readdir/Makefile.am88
1 files changed, 13 insertions, 75 deletions
diff --git a/readdir/Makefile.am b/readdir/Makefile.am
index 5e5d148..cdf1a87 100644
--- a/readdir/Makefile.am
+++ b/readdir/Makefile.am
@@ -1,5 +1,5 @@
# File: ./Makefile.am
-# Package: readdir
+# Package: (pd external): generic
# Description:
# + top-level automake file
#
@@ -7,92 +7,30 @@
#-----------------------------------------------------------------------
#-----------------------------------------------------------------------
-# Options & Subdirectories
+# Includes
#-----------------------------------------------------------------------
+include $(top_srcdir)/pdexternal.am
-## --- automake options
-#AUTOMAKE_OPTIONS = foreign dist-bzip2 dist-zip
-AUTOMAKE_OPTIONS = foreign
-
-## --- recursion subdirectories
-SUBDIRS = config src
-
-## --- pseudo-deps for '.SUFFIXES'
-SUFFIXES = .pod .txt
-
-#-----------------------------------------------------------------------
-# Variables: cleanup
+##-----------------------------------------------------------------------
+## Options & Subdirectories
#-----------------------------------------------------------------------
-## --- mostlyclean: built by 'make' & commonly rebuilt
-#MOSTLYCLEANFILES =
-## --- clean: built by 'make'
-#CLEANFILES =
+##-- aclocal options (top level only)
+ACLOCAL_AMFLAGS = -I m4
-## --- distclean: built by 'configure'
-DISTCLEANFILES = \
- config.log \
- config.cache \
- config.status
-
-## -- maintainerclean: built by maintainer / by hand
-MAINTAINERCLEANFILES = *~ \
- $(PODS:.pod=.txt) \
- Makefile Makefile.in \
- aclocal.m4 \
- configure \
- install-sh \
- stamp-h.in \
- config.h.in
-
-maintainer-clean-local:
- rm -rf autom4te.cache
-
-#CVSCLEAN_SUBDIRS = $(SUBDIRS)
-
-#CVSCLEANFILES = Makefile.in Makefile
+## --- automake options (top level only)
+#AUTOMAKE_OPTIONS = foreign dist-bzip2 dist-zip
+AUTOMAKE_OPTIONS = foreign
+## --- recursion subdirectories
+SUBDIRS = src
#-----------------------------------------------------------------------
# Additional Variables & Rules: PODS
#-----------------------------------------------------------------------
PODS = README.pod
-.pod.txt:
- pod2text $< $@
-
all-local: $(PODS:.pod=.txt)
-#-----------------------------------------------------------------------
-# Variables: distribution
-#-----------------------------------------------------------------------
-
## --- extra distribution files
-EXTRA_DIST = \
- $(PODS:.pod=.txt) autogen.sh configure \
- README.cvs COPYING
-
-## --- recursion subdirectories for 'make dist'
-#DIST_SUBDIRS = $(SUBDIRS)
-
-## --- dist-hook: when another 'Makefile.am' is overkill
-#DISTHOOK_DIRS = foo
-#DISTHOOK_FILES = foo/bar.txt foo/baz.txt
-#dist-hook:
-# for d in $(DISTHOOK_DIRS); do\
-# mkdir -p $(distdir)/$$d ;\
-# done
-# for f in $(DISTHOOK_FILES); do\
-# cp -p $(srcdir)/$$f $(distdir)/$$f ;\
-# done
-
-#dist-bz2: dist-bzip2 ;
-
-
-#-----------------------------------------------------------------------
-# Rules: cleanup
-#-----------------------------------------------------------------------
-.PHONY: cvsclean cvsclean-hook
-
-cvsclean: maintainer-clean ;
-
+#EXTRA_DIST += $(PODS:.pod=.txt)