aboutsummaryrefslogtreecommitdiff
path: root/weightmap/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'weightmap/src/Makefile.am')
-rw-r--r--weightmap/src/Makefile.am105
1 files changed, 5 insertions, 100 deletions
diff --git a/weightmap/src/Makefile.am b/weightmap/src/Makefile.am
index 7e6a420..44a8fda 100644
--- a/weightmap/src/Makefile.am
+++ b/weightmap/src/Makefile.am
@@ -1,33 +1,23 @@
# File: ./src/Makefile.am
-# Package: weightmap
+# Package: (pd external): weightmap
# Description:
# + src-level automake file
-#
-# Process this file with Automake to create Makefile.in.
#-----------------------------------------------------------------------
#-----------------------------------------------------------------------
-# Options & Subdirectories
+# Includes
#-----------------------------------------------------------------------
+include $(top_srcdir)/pdexternal.am
## --- recursion subdirectories
#SUBDIRS =
-## --- pseudo-deps for '.SUFFIXES'
-SUFFIXES = .@PDEXT@
-
-#-----------------------------------------------------------------------
-# Flags and variables
-#-----------------------------------------------------------------------
-PDEXT = @PDEXT@
-EXEEXT = .@PDEXT@
-
#-----------------------------------------------------------------------
# pd externals (hacked _PROGRAMS target)
#-----------------------------------------------------------------------
## --- externals
-pdexterns_PROGRAMS = @PD_OBJECT_EXTERNALS@
+pdexterns_PROGRAMS = weightmap
## --- possible externals
EXTRA_PROGRAMS = \
@@ -44,89 +34,4 @@ pddoc_DATA = weightmap-help.pd
# sources
#-----------------------------------------------------------------------
-weightmap_SOURCES = \
- weightmap.c mooPdUtils.h
-
-#-----------------------------------------------------------------------
-# external compilation : flags
-#-----------------------------------------------------------------------
-DEFS = @DEFS@
-AFLAGS = @AFLAGS@
-DFLAGS = @DFLAGS@
-IFLAGS = @IFLAGS@
-LFLAGS = @LFLAGS@
-OFLAGS = @OFLAGS@
-WFLAGS = -Wall -Winline
-
-AM_CPPFLAGS = $(IFLAGS) $(DFLAGS)
-AM_CFLAGS = $(OFLAGS) $(WFLAGS) $(AFLAGS)
-
-weightmap_LDFLAGS = $(LFLAGS)
-#weightmap_LDADD =
-
-#-----------------------------------------------------------------------
-# Variables: cleanup
-#-----------------------------------------------------------------------
-## --- mostlyclean: built by 'make' & commonly rebuilt
-#MOSTLYCLEANFILES =
-
-## --- clean: built by 'make'
-CLEANFILES = *.$(PDEXT)
-
-## --- distclean: built by 'configure'
-DISTCLEANFILES = \
- config.log \
- config.cache \
- config.status
-
-## -- maintainerclean: built by maintainer / by hand
-MAINTAINERCLEANFILES = *~ \
- $(PODS:.pod=.txt) \
- Makefile Makefile.in \
- aclocal.m4 \
- configure \
- install-sh \
- stamp-h.in \
- config.h.in
-
-maintainer-clean-local:
- rm -rf autom4te.cache
-
-#CVSCLEAN_SUBDIRS = $(SUBDIRS)
-
-#CVSCLEANFILES = Makefile.in Makefile
-
-
-#-----------------------------------------------------------------------
-# Variables: distribution
-#-----------------------------------------------------------------------
-
-## --- extra distribution files
-EXTRA_DIST = \
- $(pddoc_DATA) \
- $(pdexterns_DATA)
-
-## --- recursion subdirectories for 'make dist'
-DIST_SUBDIRS = $(SUBDIRS)
-
-## --- dist-hook: when another 'Makefile.am' is overkill
-#DISTHOOK_DIRS = foo
-#DISTHOOK_FILES = foo/bar.txt foo/baz.txt
-#dist-hook:
-# for d in $(DISTHOOK_DIRS); do\
-# mkdir -p $(distdir)/$$d ;\
-# done
-# for f in $(DISTHOOK_FILES); do\
-# cp -p $(srcdir)/$$f $(distdir)/$$f ;\
-# done
-
-#dist-bz2: dist-bzip2 ;
-
-
-#-----------------------------------------------------------------------
-# Rules: cleanup
-#-----------------------------------------------------------------------
-.PHONY: cvsclean cvsclean-hook
-
-cvsclean: maintainer-clean ;
-
+weightmap_SOURCES = weightmap.c mooPdUtils.h