aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-21 05:08:54 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-21 05:08:54 +0000
commit0ca6f43514c11e30d76618be69fcb995b926d0d5 (patch)
tree176c578365c3aa10b8881ac34aac7d4d0b73f4b4 /debian
parent66615de24cb4f2d3511ad4a6cee4b28058e3ebb8 (diff)
ported to new template Makefile and debianized it
svn path=/trunk/externals/moonlib/; revision=13184
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright13
-rwxr-xr-xdebian/rules16
5 files changed, 51 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..02d3ec2
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pd-moonlib (0.2-1) unstable; urgency=low
+
+ * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
+
+ -- Hans-Christoph Steiner <hans@eds.org> Thu, 21 Jan 2010 23:27:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..9606b2d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: pd-moonlib
+Section: sound
+Priority: optional
+Maintainer: Paul Brossier <piem@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), puredata (>= 0.42.5-3.1~)
+Standards-Version: 3.8.3
+Homepage: http://puredata.info
+
+Package: pd-moonlib
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, pd
+Description: library of objects related to GUI control
+ Moonlib includes three sub-sections: nilib, which is a kind of wrapper
+ between Pd and Gtk, sublib, which is a collection of gui control objects, and
+ other, which are miscellaneous objects.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..e0e4a7c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,13 @@
+Debianized-By: Hans-Christoph Steiner <hans@eds.org>
+Debianized-Date: Sat, 20 Feb 2010 17:14:25 -0400
+Files: *
+Copyright: 2001-2004, Antoine Rousseau
+
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 2 can be found in file "/usr/share/common-licenses/GPL-2".
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7c37855
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = moonlib
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+